Audiobooks not going into right files

Everytime I try to upload audiobooks, they go into Music > Albums instead of Music > Audiobooks.  This is very frustrating but I don’t know what I’m doing wrong.  The first audiobook I uploaded went perfectly but nothing’s working right since then.  Also, under Albums, it says “Untitled” and no other information.  Can I have some help, please?

Um… what sort of audiobook – a CD you ripped yourself, a file you bought or rented from a service…?  What type of file is it?

What method are you using to transfer it? How is the book that “worked” different from the ones that haven’t worked?

There isn’t enough information in your post to answer any questions.

Audiobooks from Audible.com, which are .aa files, go into Audiobooks.

.mp3 or .wma files go into Music because the Sansa doesn’t know they are Audiobooks. 

http://forums.sandisk.com/sansa/board/message?message.uid=34259#U34259

(The E200 organizes files like the View.) 

To make them easier to find, you could use tagging software like mp3tag, or the tag editor built into Windows Media Player, to highlight all the files in the folder and fill in Genre as Audiobooks. Then browse the unit by Genre (instead of Artist or Album) when you want them. 

More on ID3tags here: 

http://forums.sandisk.com/sansa/board/message?board.id=announcements&thread.id=201&view=by_date_ascending&page=1