Audio Books

I loaded an audio book on to computer, 6 discs, coverted them to mp3 and then tried drag and drop in to my Sansa clip, what a mess!    Can anyone help with this, how do I successfully put an audio book on to my little clip.

I just recently struggled through and figured this out.  Make sure your USB port is in MSC mode.  Then make a file folder on your desk top, and put your book MP3 files in it.    Use windows explorer to open your clip, media files, audiobooks folder.  Drag and drop your book folder from desktop to there.

When you are disconnected from the computer, you access audiobooks in the clip from the music menu - its about the last category in there.

With 6 disks, you may also have an issue with the tracks playing in the correct order, so I’ll offer another suggestion: download mp3tag( to edit id3 tags to get track numbers, etc, in the right order spanning multiple CDs.  (Thanks, TomJensen, for this solution.)

Make a folder for your book.  Rip each CD into subfolders called CD01, CD02, CD03, etc (if you have 100+ CDs, use enough leading zeros: CD001, CD002).  How you do this depends on your Rip software.  You may have to rename the folders after you rip the CDs.

In MP3Tag, open all of the folders (File | Change Directory to your book’s folder - all tracks in the subfolders will be opened), and Select all files (Ctrl-A).

On the menu, select Convert | Tag - Filename (Alt-1).  Enter %_directory% %_filename%  . Click OK. The filenames should now be prepended with the directory name so the tracks can sort properly in order of CD number. Click on the Filename bar twice to reorder the files to ascending order.

With all files selected, you can now use the Tools | Auto-numbering Wizard (Ctrl-K) to set the track numbers appropriately (use leading zeros).

While you’re at it, set author/Artist & book/Album name tags if they’re not correctly set, as well as genre to “Audiobook”, by changing the appropriate fields on the left side.  Don’t forget to Save your changes.

Now drop & drag your audiobook folders & files into the Clip’s \Audiobooks folder.  The Clip will now be able to properly identify each track by the id3 tags.

thanks so much for your help - will try that…

thanks so much for your help, will have to put my brain in gear and try that…

Thanks to responding to my query…Excuse my ignorance but I am not sure how to make sure the usb port is in msc mode?

havelock wrote:
Thanks to responding to my query…Excuse my ignorance but I am not sure how to make sure the usb port is in msc mode?

To change the USB mode of the player, go to Settings > System Settings > USB mode. You’ll see 2 choices: MTP, MSC and Auto (Defect).

This changes the way the player communicates with your computer. MSC makes your player look like any other ‘dumb’ storage medium, like a thumb drive, or external hard drive; something that just sits there waiting to be fed data. MTP mode assumes a device that has to be ‘managed’.

Here are two tricks I use to further simplify audiobook/books on tape playback.

Use CDex to rip one file per CD. After inserting a CD press (I believe) F10 and extract each CD as a partial track.
Begin your track at the beginning of the CD, and end at the end. This will make one track for one CD.

This is a direct link to the file; you may want to visit first to read about the program.

Use Meda mp3 Joiner. After you have a track for CD1, CD2, CD3, etc.; merge them all together so that you have one or two big files for your entire book. Make sure the files are in the right order before you join them.

Sansa Clip has built in bookmarking. You now only have one big file to keep track of so you will almost always start and stop your book at the right spot. Sometimes the clip loses the bookmark, but I have not been able to localize the conditions that lead to a lost bookmark. Sometimes I just read the counter time into the voice recorder in case a bookmark ever fails. Happy reading while running, biking, or swimming. Well, maybe not the last one.

justhelping wrote: Happy reading while running, biking, or swimming. Well, maybe not the last one.


  Nix on the 2nd one too . . .

Not only illegal in many states, but dangerous!

You need to be able to hear those ‘cagers’ comin’ up on your 6. You’ll never know what hit you if Van Halen (or even someone reading a book) is blasting in your ears. :dizzy_face: