Audible problems!

I wonder if anyone else has had certain problems with Audible manager in regards to it working for some Sansa devices but not others?

I use my Audible Download manager on a Windows 7 netbook and downloads went flawlessly with my Clip Sport and my Clip Zip (stock firmware.)

However, when I try to download on my Clip Zip loaded with Rockbox and my Fuze+ (stock firmware), it recognises the devices but goes into a loop by firstly, telling me my device has to be authorised and taking me to a new window to sign in to my Audible library, and when I do that, same window comes up again, telling me to press ok, then back to the Audible sign in again…rinse, repeat, rinse, repeat as nauseam.

No doubt I am doing something fundamentally wrong.  I haven’t gone on to Audible helpline yet because I still haven’t lost my will to live.

I hope someone can point out my newbie error!

As no one seemed to have an answer, I did some more research and worked this out!  It seems Audible does not like you to activate too many devices on the download manager, even if they are the same brand but different models.

Therefore, to load books on to my Fuze+, I had to deactivate my Sport by clicking on the remove device button on left hand side.  Then, by activating the Fuze+, I was able to populate it with my books.

In future, if I want to load more books on my Sport, I will have to reverse the process ???


Can one Audible subscriber install Audible Manager on two computers?  Then manage one specific device on each PC?

   What about two “users” on the same PC?

No, I tried installing Audible manager on two different laptops but same problem occurred.  Presumably because it is linked to your Audible account (?). The manager allowed downloading with Sport and Zip but not Fuze.

Whent through this with a Audible tech yesterday. You are limited to 3 activated devices of which your computer is one. Deactivate one of your devices and see if that works. If it doesn’t, call Audible and they can deactivate them in your account. Had to have them deactivate all devices.