Audible manager - 'device specific error'

I’ve just been given a Sansa Fuze, so wanted to download some books.  I’ve added Sansa Fuxze to my list of devices and Audible Manager is reading that it’s connected, but when I try to download 9in format 4) I get the message that it failed to transfer and there is a Device Specific Error.

I searched for information about this, but can’t find anything. Would be grateful for assistance

ETA  I’m using Windows XP

Message Edited by Psyche on 04-29-2010 03:48 PM

You must connect the Fuze in MTP Mode , and first authorize the device, using the Audible Manager.

Do you have Windows Media Player 10 or later installed? WiMP 10 or 11 is needed for MTP support.

Bob  :smileyvery-happy:

The device is authorised with Audible and it shows it is reading it when I connect. I’m in MTP mode. I had WiMP10, but upgraded it to 11 last night just in case, but even so am still getting the same message that there is a device specific error

In the Audible Manager, click on Check For Updates, and install the Sansa / SanDisk digital players plugin, at least be sure it’s installed from the list.  The “nuclear option” may be the hot ticket as a last resort: be sure to have backup copies of your music first.

On the player, format the device using Settings > System Settings > Format > Yes. Remember, this will erase all media from the device, so have backups first.

Lastly, reauthorize the Sansa using the Audible Manager, and transfer your audiobooks!  The Fuze accepts Formats 4 and Enhanced only; the more compressed formats don’t work with the latest firmwares.  Format 4 has a very clean sound, but my personal favorite choice is format 3, which doesn’t run on the Fuze, unfortunately.  (It does on my little e280.)

Formatting the device forces a synchronization of the secure clock, part of the DRM system, which just might be your issue here.

Let me know how it goes!

Bob  :smileyvery-happy:

Well, I tried this whole process twice and it has worked.

Many thanks for your help.

I really want to share that app ‘audible audiobook converter’ with you. Really great! Via that, I customzie my audible audiobook according to my demand. Otherwise, I can manage my audible audiobook by artist or album.

I use an Audible audiobook converter to change the format to MP3 when I met this problem.  Then these MP3 audiobooks can be imported to any device and player. Even it doesn’t support AA/AAX formats. Hope it can help.


To convert Audible AA books to MP3, I have been using AudKit Audible to MP3 Converter for a long time. The conversion speed is close to 100X that only takes 1 sec to convert a 10-hour-audiobook. Now the Audible MP3 books are playable without the Audible app.

Hi, happy to hear that your issue has been fixed well. Here, I’d like to share another way to download and play Audible audiobooks on Sansa Fuze. It uses Audio Converter Mac or Windows to download audiobooks as Sansa Fuze compatible files on your computer. And then you can directly sync audiobooks to your MP3 player for playback. No need to use Audible Manager anymore so you don’t need to worry about the issue of ‘Device Specific Error’.