ARGGG!! Wheel doesn't work!!

I am getting so frustrated with this thing.  I know I am not all that tech savvy, but jeez, how hard can it be??  I think I may have a dud instead of a bug. I tried updating but it still having same problem.  I will try my best to explain.  After I have been listening for a while(30mins?) my wheel will not work.  If I try to change a song, it will not do it.  Actually, the home button doesn’t work either.  If I do get to the main menu, and hit music, it keeps going back to the main menu and will not let me do anything in music.  It is like that in all of them, settings, voice etc…  like it is too sensitive maybe?  Am I making sense?  I can’t change anything on it easily.  Sometimes not at all.  If I cut it off for a while and then try again, it will let me for a few minutes.  I have tried refreshing when it is stuck like that and it still want work.  Sometimes I can’t even get it to refresh.  Is that what it does when it freezes up?  I think the dial may be just jacked up.

I just got this in Dec and if I continue to have issues, I am sending it back.  I still can’t get videos to load, but that is a whole other issue.  I hate that Ipod has such a monopoly on mp3s, but it seems that that it really is so much easier with them.    My sons have Ipods, but I purchased this one for myself for the cost, but I am starting to regret.

Sorry so long.   I would appreciate any help possible!!

Did you try to reboot it by holding the button in the on/off part for 15-20 seconds? Also, I can’t really tell if you have the latest firmware. If not, download the updater and follow the instructions. If it fails, then try to manually download the update (there is instructions to do this on the firmware update thread).

Thanks for replying so fast:)  I did reboot(many times) and I did the update manager too.  I was really hoping that that would do the trick, but it didn’t.  Thats why I was hoping that someone on here might know what to do.  I usually do a search and find any info I need, but it was hard to word this problem to find an answer.  What luck, huh?  I swear, I think I radiate some sort of magnetic field that destroys any technology around me.LOL

Reload the firmware manually. There is thread here about it. Follow the instructions in the first posting there.

Alright, try to format the player then. If that fails, it could be faulty parts.

I am about to start crying, I am getting so aggravated with this thing.  I am about to throw it out the window.  I have been trying to fix this thing for HOURS which is pretty hard when you have four kids running around.  I can’t format it because the select button is not working.  When it does work, (sporadically) when you turn the wheel, (ex.  settings-when you try to scroll down it goes back to main menu, I can’t get it to stay on settings to get to format.)  I can’t even get to settings to put it back in MTP (or whatever it is) mode so I can format it in WMP.  I have tried manually updating it, but the only one I haven’t downloaded is the user manual. I guess I just got a lemon.  I bought it from and I guess you get what you pay for.

I don’t really expect a solution to this, just wanted to vent :angry:      I will be calling tech support before I totally give up.  I will also be writing a nice letter to management.  Thanks for the input.  I will post whatever solution happens.


Just a quick check to ask if you are pressing the correct buttons.  When you use the scroll wheel to select Music, are you pressing the button in the center of the scroll wheel (or alternatively the right-arrow button which is the right side of the scroll wheel)?  Pressing the other button outside the wheel will just return you to the main menu.

The center button.  That’s the right one, isn’t it?  I thought that might be the case so I looked it up and the center button is the select button. Right?  I was hoping that I was wrong and that the solution was that simple.  Also, when I turn the wheel, it goes back to the main menu.  It acts like it is possessed and does all kind of crazy things, including record when I have no idea.

When you turn the wheel, are you using a very light touch, or pressing hard?  If pressing hard, maybe you are triggering buttons while turning the wheel?  Sorry, nothing else is obvious to me.  Maybe you will need to call tech support?

momoffour wrote:
The center button.  That’s the right one, isn’t it?  I thought that might be the case so I looked it up and the center button is the select button. Right? 

This sounds like Lucy & Desi in ‘The Long, Long Trailer’ where she says, “Turn right here.” Desi turns his big boat of a car plus the trailer he’s towing right onto this dinky dirt road.

“You didn’t let me finish” Lucy cries, “I started to say, turn right here left!” :smileyvery-happy:

Sound like you got a bum unit. Take or send it back and get another one. You’ve got enough aggravation with 4 curtain-climbers running around; you don’t need any more. :wink: