Anyone Know How To Repair This?: "This vault coul not be loaded..."

Thanks for taking the time to read this.


32 GB Cruzer
Sandisk SecureAccess 2.0.


I’m using SanDisk SecureAccess Version 2.

Note that I have access to the vault, so it’s not a matter of getting into the locked vault or needing password help. When I login to the vault, I get the following error message:

“This vault could not be loaded, it may be located on another computer or the original vault files have been manually removed”.

I see the vault image, but it will not load to give me access to the folders inside.

So I’ve got all the files and access to them; they’ve just been converted to the “.dat” format, so I cannot use them. Need it to have the vault recognize those files, so I can see them in the original format they were created OR just have the encrypted files converted back to their original form, without the vault.

What I’ve tried:

“Repair IDX/Bak” solution found here:

Also tried to change the SecureAccess version to 1.0 and 3.0 to see if I could view the files under a different version of the files; no luck.

So if anyone can help me either…

  1. Repair the vault, so I can access it again.


  1. Decrypt the .dat files so I can view them (different types of files, so I cannot just keep using different programs to try to guess which files are which).

That would be great. Thanks.

  • Ken

Decrypting the .dat files is not an option.  And writing over the drive with different version updates hasn’t helped.  You need to start fresh.

Thanks for taking the time to read and reply, Ed. Much appreciated.

Trying diffrerent versions of the SecureAccess program did not prevent me from reverting back to the original 2.0 program and accessing the “vault” error again.

I can return back to square one of the problem at any time.

Good to hear you have backups Anon.  Hopefully one before the error started showing up. :wink:

I have backups of some of the files–I don’t believe in leaving one point of failure—so many of the files in that locked vault have duplicates stored elsewhere.

However, there are files in that vault that I do not have back-ups of. 

That image I posted is just a picture of the inside of the USB card.

USB Layout as follows:

Click  on the drive and you get…

  1. Sandisk Vault
  2. Sandisk app - Mac
  3. Sandisk App - Windows

Click on “Vault” and you see the following setup…

1)Folder - System files

Inside of the system files folder, you have these files:

USB Flash Drive-200548613218C252A56C.idx

  1. All of the .dat files, which are NOT inside of the System Files folder.

Clicking on the Sandisk App is how the vault is opened.  I cannot open the vault—I keep getting the error explained in my original post.

So I’ve got no access to the decrypted files.