any one help me

I purchased the Sansa almost a year and since that time can not my computer or any other computer to recognise it …I USE (xp)…Please Help needed essential…i wait

Is this the Sansa Connect?

You say no computer you’ve tried can recognize it, so my guess is the problem is with the Sansa Connect, but just to make sure … you need to have Windows Media Player version 10 or 11 installed in order for a computer to recognize it.

You could try reinstalling the firmware.  If you don’t care about the WiFi capabilities, follow these instructions:

http://kb.sandisk.com/app/answers/detail/a_id/863

If you want the WiFi capabilities, read the last post in this thread:

http://forums.sandisk.com/sansa/board/message?board.id=connect&thread.id=2793 

If you’ve reinstalled the firmware and you’re still having the same problem … have you been using the same USB cable every time you try it?  It’s possible the cable is damaged.  (Though if that’s the case, you won’t be able to reinstall the firmware using that cable.)

Message Edited by PromisedPlanet on 12-09-2009 09:31 AM

Thank you for your reply much, but I followed the instructions in the first link, but I absolutely could not carry out instructions correctly and also the image of existing device, which is not like owning (which is the owning Mba Sansa 2g blue )…I downloaded Sansa Connect No-Wifi Recovery Tool (.exe, 66MB  ) I SET IT UP but i cant compelete>>so  please help me again and explain  to me in detail, O Savior  promisedplanet>

You need to tell us exactly what happened.

You say you set up the recovery tool, but then you couldn’t “complete” it … what do you mean?

Also, are you sure you own a Sansa Connect 4GB, or do you own some other Sansa model?

Message Edited by PromisedPlanet on 12-09-2009 11:45 AM

I COULDNT do this(While holding down the Right Button, and Volume Up Button,
press-and-release the Power Button. Keep holding the Right
Button and Volume Up Button. After a few seconds, the device
will start and display a “Recovery Needed” screen.)

Make sure you’re holding the Right button, which is the button directly underneath and to the right of the screen, NOT the right edge of the scroll wheel.

![](file:///C:/DOCUME%7E1/MIMOWA%7E1.MAH/LOCALS%7E1/Temp/moz-screenshot.png) ![](file:///C:/DOCUME%7E1/MIMOWA%7E1.MAH/LOCALS%7E1/Temp/moz-screenshot-1.png)http://www.sandisk.com/media/18974/black_130x89.jpg       >>>>>>>>>click the previous link >>>>>>its my device( tiny MP3 player)not the device in the second link in your replay

![](file:///C:/DOCUME%7E1/MIMOWA%7E1.MAH/LOCALS%7E1/Temp/moz-screenshot-2.png)my device is( sansa mp3 player  2gb blue)>>>>>>>>>>like this>>>>http://www.sandisk.com/media/18974/black_130x89.jpg

That’s a Sansa Clip, not a Sansa Connect.  Post your question on this board:

http://forums.sandisk.com/sansa/board?board.id=clip

Iam so sorry forgive me and i send you agreat thanks for your great cooperation and ihope that we become afriends