activating my fuze+

when i tried to play an audio book on my new fuze+ it said i had to activate it i thought when i did the firmware update for it when i got it that it was. can some one please help me find a solution to my problem

Did you get your books from Audible? If this is the first time your gonna use the Fuze+ with audible, I suggest that you Remove the device first from its list then make sure you update your Audible manager to 5.5.05. After updating, add the Fuze+ again and load a new book.

Audible Help

Starting with Audible books, first install the Audible Manager on your computer, then log in.  You’ll then need the SanDisk Digital Players Plugin, found via Check For Updates.

Then download your books!  Choose either Format 4 or Audible Enhanced.   (The Fuze+ requires either of these formats.)

Plug in your Fuze+, and you’ll see it listed in the Manager screen.  Select Add Device, and this authorizes your player.

Click on your downloaded books, and the Add To Device button will be available.  Transfer them to your Fuze+.

Now the fun part!  Unplug, and enjoy your book.  In the future, with the Fuze+ connected, you will see the bookmark point where you left off in your current book. If you’re sitting at the computer doing other things, for example, you can enjoy your book while you work at the computer.

Bob  :smileyvery-happy:

I am having the same problem.  I have downloaded books from onto itunes on my MAC.  I’ve dragged and dropped into the fuze+ but when i try and play the book it says “please activate your device to play this title”

Please can someone help

Thank you!

files from audible have to be synced to the player using the audible manager. these files are protected by DRM and just drag and drop does not transfer the licence

I took my 16 GB MicroSDHC card from my defunct SanDisk Clip+ and stuck it in a new Fuse+. The microSDHC card contains audio books from The Fuse says, “Please activate your device to play this title.”  What is activation? Thank you.

(In reference to my earlier post. ) By the way, the documentation that came with the Fuse said that all one has to do with a microSD card is stick it in, and you’re good to go.

Your Audible books will play, once you have authorized  the Fuze+ using the Audible Manager.

Audible has improved their licensing method. Once the device is authorized, audiobooks are “portable” between your devices. In other words, if you transfer to the microSD card on one device, the books will play on up to three authorized devices. Previously, the books would only play on the device that had been transferred to.

Open the Audible Manager and plug in your device. Select the Fuze+, and click on Authorize. After this, you should have no problems with those books on your microSD card!

Bob  :smileyvery-happy:

Bob, Agreed this should work, but it hasn’t for me.  On my second replacement Fuze (not plus - don’t like new control) now (why do they keep malfunctioning?) and with this new one I just can’t get the fuze to activate… tried various published options and now waiting for a reply from Audible, the microSD has the file but the fuze won’t let it play.  Will post if I get a solution, meanwhile good old Clip…

Like most things the answers are often so easy, when you know what to do…  After leaving 4 message with Audibly asking for help and after trying everything suggested on their web site, a thought struck me.  Although I am the administrator on my computer, I restarted, went to Start, All programs, AudibleManager and opted for [right click]  Run as Administrator.  When the program opened I selected activate and – yes – Activation occurred…  Hip Hip.  Hope this help someone - seems clear that Audible don’t want to offer any help…:confounded: