A few issues. Please help.

1)Yellow dot next to battery light is always on. Don’t know what this is.

2)Can’t figure out how to update firmware. I tried holding center button while connecting USB cable. Still no way to drag or copy firmware to device. Found no root folder.

3)Power is always low. Never fully charges. Dies very quickly no matter how long I charge it.

What yellow dot? Not sure what you’re referring to…

Charging the battery should take about 3 1/2 hrs, I recommend doing this before attempting anything else with the Sansa Clip. Once the battery symbol stops flashing, it’s fully charged. If the battery self-discharges within a day or 2, you have a defective Sansa Clip & you’ll have to exchange it. The average “playtime” of the battery is 15 hrs, depending on your settings & file type.

To update the firmware, download the zip file posted here: http://forums.sandisk.com/sansa/board/message?board.id=clip&thread.id=2946 , extract the bin file to your computer, plug in your Sansa Clip, open windows explorer, locate both the bin file & the Sansa Clip(should be detected as a removable device), copy & paste the bin file to the Sansa Clip’s root directory, unplug the Sansa Clip, & the firmware upgrade will begin. When that’s done, the Sansa Clip will shut off. Turn it on again, & the database will refresh. Voila! You will now have the new firmware.

I hope this helps! Let us know if you need any further assistance.

the dot (red,yellow, green) represents your subscription status. Green means you have like 30 days, yellow is liek 15 days left, and red is none. I could be off by the days, but the general idea is there.

For Clip the dot is always yellow,  but it get less filled in as the subscription becomes due.  Check the screen under Settings>Account

for the example icons.

This indicator is for Rhapsody subscription status only.

I do subscribe to Rhapsody, so I understand the yellow dot now. But the firmware is another issue. I find no root directory to install the firmware file into when I open the clip in “My Computer.” It shows “Internal Memory” ,which can’t be pasted into, and after double clicking it it shows albums, music, playlists, record, service, and DevIcon. And nothing else.

There is no folder there saying “Root”. The root folder is that part where you see folders like “music”, “voice”, etc. and the other .sys files.  That’s where you will have to paste the .bin file.

Stumped, if you have a defective battery you might want to have your Clip exchanged before spending too much energy on getting the firmware update working?
Have you tried charging it from a different USB port, or even better from another computer? (maybe the USB port is the weak link)

 “Internal Memory” (…) it shows albums, music, playlists, record, service, and DevIcon.

This is with the clip in MTP mode, and is where the firmware file (m300a.bin) should be placed. The “root” does not refer to an actual folder name, it’s the term for the first or top-most directory in a tree structure.

Alternatively MSC: It sounds like you have not succeeded in connecting in MSC mode (where the Clip will simply show up on your computer as a Removable disk and with a drive letter (like “E:” or “F:” ): Slide switch on left side down to the Hold position, then hold the center button while connecting USB cable until coumputer detects the device. Then your root folder will contain Audible, Music, Record folders and some .sys-files. You then place the m300a.bin here, and disconnect.

HTH.

Message Edited by SajmonDK on 02-08-2008 08:15 AM

Sajmon, thank you. I didn’t realise that the hold switch had to be engaged in order to enter the MSC mode. It worked like a charm, and the firmware took.

I have tried charging on an external usb power source as well as my laptop, so I don’t think it’s the usb source causing the low battery problem. With the new firmware I’ll try charging it fully again before exchanging it.

Thanks everyone.

Please note; you CAN drop the FW file onto the Clip in MTP mode (there is a lot of confusion over this), but you must “open” the device (by double-cliocking on it) and be viewing the files on it in a window. Then you drag-n-drop into the file listing window - NOT to the device icon itself directly.

Try it again, you’ll see that this does work