8GB Sansa Clip+ "Not enough space..."


I wanted to use this player with linux, so I set the USB mode to MSC.

With linux there was only 2.8GB free, so I formated the player (info from SanDisk support).

Then I load 5GB of MP3 files to the player (with the midnight commander) and “ejected” the device.

Now I gets the error message:

"Not enough space für Music DB.

Please free 90MB",

and the player switched off.

I read other threads with nearly the same subject, tried to reset the device (pushed the power button more than 3 minutes), connected the player to my linux PC and to another windows pc, but nothing helped.

Is there any hint to reanimate the device?

thanks for helpfull answers



I know this Knowledge Base Artikel. It not possible to delete any file, because the player shuts off after a few seconds and I can not change to any menu item. The device is not shown, not in Windows and not in Linux; I can not delete any file with the system tools because I can not acces the player.

What you can do to get the player recognized by the computer, preferably a windows PC, is to “force MSC mode”.  To do that, turn the player OFF, then hold down the center button while you plug the player into the computer.  You may have to keep holding down the center button for a while until the player is recognized.

If the player doesn’t get recognized, then I recommend just leaving it plugged into the computer, after trying to force MSC mode, in case the battery is very low and it just needs to be connected to a power source until it gets a good charge.  It may take overnight, and sometimes a full day before it’ll “wake up”.

For Linux I set the USB mode from auto to MSC and I tried the “force MSC mode” as the disaster occured. Today I started the player again and pushed all the buttons (‘cursor’, center and home) in chaotic order and I get a new message: “Refreshing your media” Then I could really connect the player to my Linux PC and formated the memory, first with Linux and then with the format Item in the player menu. Now the player ist ok, but I could not give a step by step instruction to solve this problem. Thanks to all who tried to help me

I faced the same problem and solved the problem using the software “SD formatter”.

You can download it from the SD Association

The format does not erase the sansa system files.

How do You format a drive that You can not connect as a drive?