8GB Fuze will not stay in MSC mode (Windows 7)

So, after reading all the random problems people have with this thing, I think I have a slightly different one. 

Here is the rundown.

So plugging in the Fuze into my win 7 machine, it connects via MTP by default.  After a while, even after updating the firmware, windows started having issues recognizing the device.  Just like many others have experienced.  I set it to MSC mode, but for some reason, it does not stay in that mode (or charge) unless I a) force MSC mode by using the hold button and  b) actually physically hold the “left” button the entire time i want it connected to the computer.

So imagine me sitting there, holding the “left” button, so that I can drag music into the fuze and so that it can charge.  If I let go of the left button it goes back to MTP mode, which does not work (windows had problem installing the device messages come up). Even if I set the Fuze to MSC in the settings this thing won’t stay on it unless I physically hold the button.  This is ridiculous.  Am I supposed to leave a heavy rock on this thing so that the left button stays pressed while it charges and so that I can add music? Windows 7 recognizes the device if I sit there like a dumb ass holding down the left button.  I really shouldn’t have to do this at all.  Is there any other way to lock in MSC mode? Pleae let me know.

Thanks.

Message Edited by mixmasterp2k3 on 02-03-2010 04:29 PM

Sounds like some Micro$oft “feature” added to the ever exciting Windows 7. 

Just an an experiment, what happens if you set it to MSC (you’re definitely NOT on Auto Detect, I trust), let Windows not find the driver…and then go into Device Manager (via Control Panel and whatever devious path Windows 7 has) and Uninstall the exclamation point. Maybe it’ll stay in MSC?

I don’t know if it will work, since I’m on XP until they pry it from my cold dead hard drive.  Worth a shot, though.

Meanwhile, let’s hope SanDisk is talking to M$. This is something you should call 1-800-SANDISK about, since they may have a fix and if not, it will make them aware of the problem. 

Black Rectangle,

I tried that too.  Everything in the FAQ and Sansa’s own troubleshooting tips failed me.  The most infuriating part of this ordeal is that it functions perfectly in MSC mode on my netbook with XP sp3.  No problems. It charges up and functions how it should. Thing is, none of my music is on my tiny netbook. My work and home PC all run Windows 7 Ultimate.  Perhaps something went horribly wrong with how the Fuze drivers are recognized between operating systems? It is embarassing how much time I have spent trying to get this thing to work in Windows 7.  I love Sansa products and I will forever refuse to bow down to Apple products and attrocious things like itunes.  So I may have to call into tech support because I really do want this thing to work. 

I mean seriously, I don’t feel like putting a 10 pound weight or clamping down the left button on the Fuze just so it stays in MSC mode and able charge it on my Win 7 machine. Sadness consumes me. 

You shouldn’t have to. It’s obviously some devious Windows 7 thing, and it’s truly obnoxious that M$ has decided to automate good old hands-off MSC.

If SanDisk isn’t already working on this, it should be, so do call them–and if they already know how to fix it, it would be great if you could post the solution. 

Workaround: Establish netbook-PC network connection. Use netbook to sync over network share.

mixmasterp2k3 wrote:

So, after reading all the random problems people have with this thing, I think I have a slightly different one. 

 

Here is the rundown.

 

So plugging in the Fuze into my win 7 machine, it connects via MTP by default.  After a while, even after updating the firmware, windows started having issues recognizing the device.  Just like many others have experienced.   I set it to MSC mode, but for some reason, it does not stay in that mode (or charge) unless I a) force MSC mode by using the hold button and  b) actually physically hold the “left” button the entire time i want it connected to the computer.

 

So imagine me sitting there, holding the “left” button, so that I can drag music into the fuze and so that it can charge.  If I let go of the left button it goes back to MTP mode, which does not work (windows had problem installing the device messages come up). Even if I set the Fuze to MSC in the settings this thing won’t stay on it unless I physically hold the button.  This is ridiculous.  Am I supposed to leave a heavy rock on this thing so that the left button stays pressed while it charges and so that I can add music? Windows 7 recognizes the device if I sit there like a dumb ass holding down the left button.  I really shouldn’t have to do this at all.  Is there any other way to lock in MSC mode? Pleae let me know.

 

Thanks.

Message Edited by mixmasterp2k3 on 02-03-2010 04:29 PM

Most of the posts I have seen where people’s computers stopped recognizing their Sansas were with XP machines, where MTP was not a native function. It could be added, via a porting kit or WMP11, but was not native.

You, however, are in Win 7 Ultimate. So…there is an option available for you to try, that Mr. Tinfoil Hat ( Black-Rectangle) probably also wouldn’t trust.Use virtual XP, which is available within 7 Ultimate. It’s worth a try. I haven’t needed it, so I can’t say for sure whether or not it will solve your problem, but either this, or Tom Jensen’s idea in post #5, are your best bets. :wink:

I have Win 7 Home Premium and all of my Sansas connect just fine (no different than in XP) in MSC mode…and stay in that mode.  Don’t know what is going on, but it’s not the fault of the design of Win 7.

Well, last night, I decided to use a small vice grip to lightly hold down the left button while connected to the machine forcing MSC mode.  Oh guess what, that crapped out too.  Now it will not work in either MSC or MTP which means to me GTFO.  The drivers are not recognized at all. I have not tried it on my netbook, which is the only thing left with XP at home. Really pissed off that I will need to take this thing back.  I am not going to jump through hoops just for the sake of an MP3 player.  My time is money and I already spent two days doing everything I should to get this thing working. This is horrible, becaues the Fuze is awesome. Good thing I got this at Costco where I can take everything back no questions asked. I may just wait it out until somebody at Sansa figures this out.

Other Windows 7 users aren’t reporting this problem, so it could be something about your Win7 configuration. Or it could be a defective Fuze.

Message Edited by TomJensen on 05-03-2010 06:29 PM

I have no problem with my Fuze 4gb in MSC mode and Windows 7 Enterprise. Firmware was latest, and release before latest.

I got two machines with 7.  Niether of them likes the Fuze right now.  The funny thing is my 2GB Clip works flawlessly on both.  They need to make an 8GB+ clip! That would be sick! So yeah, could just be this particular Fuze. 

mixmasterp2k3 wrote:
I got two machines with 7.  Niether of them likes the Fuze right now.  The funny thing is my 2GB Clip works flawlessly on both.  They need to make an 8GB+ clip! That would be sick! So yeah, could just be this particular Fuze. 

They do…I’ll be getting one sometime in the next week or so.:wink: