8GB clip shuts down when plugging in the USB cable

I can power my 8GB clip fine, but when I plug in my computer’s USB cord to sync, the Clip shuts off. I have tried a new cord, and I have another Clip that works fine and the computer recognizes it.


By any chance, could it help to set the Clip’s Settings/USB to MSC, if it’s not already?

Sorry for the delay, I tried switching to msc and that didnt help. Thank.s

The clip will not operate normally when plugged into the computer usb port (as opposed to connecting to wall power). When I plug my unit in either powered on or off, the display will show some icons and the word Connected and the charge indicator will indicate charging. Any music being played will cease. I always use the safe to remove hardware option on the task bar. I only use MSC mode. If your unit doesn’t do that, try the trick of moving slider to hold position, then plug into usb while pressing the  center button. This will force connect in MSC mode.

That didnt work either. the unit shuts off whether I am plugging into the computer or a simple recharger. It is currently in MSC, but I have tried all three settings. Since it wont accept power, the unit is about to power off (from lack of battery charge). I am hoping that fixes something, but in the meantime, I am at a loss.


Can you leave it plugged into the AC overnight, and see if i will charge up?  If that doesn’t work, I might phone SanDisk–this may be a defective Clip.