4GB Sansa Clip+ frozen, won't reset, computer doesn't recognize it

I’ve had the 4GB Clip+ for less than 2months. It’s FROZEN.NOTHING. Tried every reset option I could find. Looks like I’m not alone with this problem. Sansa+case+microSD+chargers=I’m out considerable $ for less than 2 months use. Disgusted.

@drzolla wrote:

I’ve had the 4GB Clip+ for less than 2months. It’s FROZEN.NOTHING. Tried every reset option I could find. Looks like I’m not alone with this problem. Sansa+case+microSD+chargers= I’m out considerable $ for less than 2 months use. Disgusted.

No you’re not. At only 2 monthes old, it’s still under warranty. Call SanDisk Tech Support. If they cannot help you get it going again, they will replace it.

No need to be busted _ and _ disgusted. :stuck_out_tongue:

After a year of relatively heavy usage my 4G Clip+ has started exhibiting this random freezing behavior.  My experience is that holding the reset *longer* isn’t any more effective.  I just keep repeating the reset process until the player comes back.  Sometimes it takes 10 resets, but (so far) it has always come back (reset for 10-15 seconds, rest for 10 seconds, repeat).  Only once or twice have I actually had it come back after a single reset. Normally, it’s at least 3 resets before it turns on - and it’s completely unresponsive in the meantime (plugging into the computer or charger does nothing). 

I limped along with this “fix” until I was finished with some DRM-protected material, but yesterday I finally reinstalled the firmware.  As this issue was in no way predictable or reproducible, only time will tell if this action provides a more acceptable solution to the issue, but it’s worth a try.  It was freezing 3-4 times a week, so I should be able to tell within a few weeks if there is any improvement.

Update: it’s been a week since I manually updated the firmware on my ailing Clip+ and it hasn’t frozen once since.  It was already at the current version of the firmware, but reapplying seems to have refreshed it.  As I said in my previous post, it was freezing up 3-4 times a week, so at this point I think the problem is fixed.

Thanks for the update and the reminder as to the efficacy of a firmware “refresh.” 

Thanks for the update and the reminder as to the efficacy of a firmware “refresh.”   :slight_smile:

I had this problem ‘4gb-clipit+ froze while playing music, and neither power button nor  computer connection would bring it back to life.’

I looked at the support page for a while and tried the ‘force MSP mode’ option as follows:

* Hold down the center button while connecting the usb cable to computer *  and it seemed to  bring it back to life.

now it is starting up normally and all my music is still there…

I’ll repost if the problem reappears- and this may not be helpful to those that need MTP mode…

1 Like

what does this have to do with the question at had

your not alone same here it sucks we lost money i liked the player it was convienent

held power button for five minutes what now

that doesnt work either

pinhole is mic dont work can anyone tell me something helpful

your just retarded

is there any useful info here

ive got a brand new state of the art computer nobodies ideas work get back on track

who cares we are talking about the sansa clip

A mind is a terrible thing to waste . . . .      :wink:

Just had this (frozen) for the first time with my 2 gig Clip+   … JUST after I had fully re-charged it … let it sit for a half hour and started listening to it … it only lasted about two minutes before it “froze”.

After checking this thread … I was able to get it back up by using the “keep repeating the re-set procedure” method, but if it continues to act up may re-install the firmware.

NOTE: I bought the 2 gig model because it was way cheaper than getting a bigger one. I’ve installed a 16 gig micro SD card and put most of my music on *that*.  Current prices for flash media are way cheaper than manufactures can match with internal memory … and, I can pull it out and put it in another unit and not have to re-load all my music.

Just wanted to post that I was having major issues with my SanDisk Sansa Clip+ including…

  • player turning on and music starting, but no screen

  • screen randomly disappearing (going black) and appearing

  • music stopping

  • player not turning on at all

I did the reset option (hold the power button for 30 seconds) and it would occasionally help. I formatted the memory (using the option in settings) then tried switching the mode… no luck. Then it stopped responding all together, not even connecting to computer worked.

I was able to get it connected to computer AND running properly by doing the following…

1.) Press and hold the large center button on the front AND connect the USB cable while holding the button down. This forces MSC mode.

2.) Visit the following thread… http://forums.sandisk.com/t5/Clip-Clip/Sansa-Clip-Firmware-Update-01-02-15/td-p/150227 and download the Sansa Firmware Updater

3.) Run the “exe” file and it should recognize your player and begin downloading new firmware. The version on my Clip+ was 01.02.09. It downloaded a ~21 MB file and installed in on my player automatically

4.) Once the process is complete, the program will tell you to disconnect your player. Do this WITHOUT exiting the updater and WITHOUT turning off your player.

5.) Your player should say that it is updating the firmware… mine did this then went black again

6.) Turn your player back on and cross your fingers… it should work!

Since doing this, my player works like new! Hope this helps someone.

Best of luck!

Thanks for the helpful info.   :)    Along with a player reset, reinstalling the firmware, even if you already have the latest version, sometimes can be helpful (see the firmware upgrade sticky thread at the top of the forum)–firmware can become corrupted over time.