4GB Clip+ won't pause and random shut-offs with podcasts.

The following behaviors only happen with podcasts on my 4GB Sansa Clip+. I’ve never had these things happen while listening to music.

If I pause a podcast and shut off the device, there is a chance that later on when I start it up again and continue listening that I lose the ability to pause the show. If I press the pause button, it’ll stop for what seems mere milliseconds and then continue on its own.

Another problem is that occasionally I’ll be listening to a podcast and then out of nowhere the device will just shut off. I’ve been able to catch it during this and see that the screens displays the “Goodbye” message before it shuts off on its own, it doesn’t just die. I assure you that I didn’t accidentally bump the power button on my own and I keep it in locked mode during playback anyways.

I only bought it a month ago and it has been doing this for the last week or two. What should I do? These two issues are mildly annoying.

OK, 3 thoughts, in case you haven’t tried these possibilities:

1.  Try a system reset:  hold the on switch down for up to 30 seconds.

2.  Try reapplying the latest firmware–it could have become corrupted over time (even a short time!).  See the firmware upgrade sticky thread at the top of the forum.

3.  If 1 and 2 don’t work, telephone SanDisk for a warranty replacement–it’s very easy to do (and they cover shipping).  In the U.S.:  1-866-SANDISK (726-3475).  And other SanDisk contact information:  http://www.sandisk.com/sandisk-support/contact-us.  Or, if you purchased locally and still can, return the player for a new one–this might be the easiest way to go for you.

Are you sure the battery isn’t out of power when it just shuts down on its own? Make sure the player is fully booted before pressing the play/pause button. Some have reported that on some Sandisk players if you press the play/pause button before the player is fully booted, then the play/pause button might not work again until the player is rebooted. Other operating abnormalities might also also occur if you don’t let the player fully boot at startup.

So - I’ve had my Clip+ (4GB, with a 16GB SDHC card) for about a month now, and so far I really love it.  Oddly enough I have noticed two different anomalies on a few different occasions and I just decided to check here on the forum today to see if either of the problems had been experienced by anyone else.  And guess what, the only two problems that I’ve had are the ones that are being described here! 

So, what I can tell you about my problems are that they were both experienced while my clip has had the battery life at over 50%, was playing either MP3 or WMA files (audiobooks, in the audiobooks directory, and both times the files were known good, 32kbps, and had fresh, uncorrupted ID3 tags) - my player had been playing for a bit when I experienced both problems and the screen had already shut off  - my timer is set at 15 seconds until it turns off (and the sleep timer is not on). The player like I said is only about a month old (from Amazon.com) and I have not tried to upgrade the firmware.

The first problem that I had was the inability to pause the file that was playing.  I pressed the play/pause button, but the file kept on playing and (if I remember correctly) the Play icon on the screen did change to the pause icon - just didn’t actually pause the file playback.  This happened a couple of times (different files I believe) but in both cases the problem was remedied by powering off, and the turning on the player, and then the play/pause acted normally. 

The other problem just started today:  the player was playing an audiobook file, and without warning (I was driving, so didn’t see the screen when it happened) the player just powered off.  Turned it back on and it happened at another time later in the day.  Again, the battery was at about 75%, and I know that nothing hit the power (or any other) button as the player was by itself on my passenger side seat.

So - sounds like my problems are similar - I just thought I’d share this with everyone, you’re not alone… :wink:

Hopefully, just gremlins at work … and they’ve gone on to other pastures.

You could try a system reset (hold the on switch down for 15-30 seconds), and/or reapplying the firmware (in case there was a firmware corruption). 

My 8GB Clip+ has EXACTLY the same symptoms. It will occasionally just randomly shut off despite a fully charged battery. This is a real nuisance because it often happens while I’m driving, and when I turn it back on, I often have to navigate back through the menus to get back where I was and resume. This isn’t something I want to have to do while in rush hour traffic on the freeway.

A second annoyance is that it often switches into a mode where it won’t pause. From time to time (about once a day for me), I’ll push the pause button, and the sound skips a beat, then keeps on playing. Again, when I need to pause to pay attention to something in traffic and my Audible book or podcast keeps blathering on, it’s quite a nuisance. Like others with this problem, I’ve found that the only thing I can do in this situation is to turn the power off then restart it when I want to “unpause” it again. I haven’t tried replacing the firmware yet, but I guess that’s next…

In case Sandisk is unaware of this problem, the exact same thing – spontaneous shutdowns with full battery and spontaneous “I can tell you’re pressing the pause button but, no, I won’t pause” mode – is happening to many of us. A clue for the programmers, in case it helps: once when I had the no-pause problem and I WASN’T driving, I looked closely at the display. I found I could hold down the rewind button and the play clock would decrement, as expected, but the audio just kept going as I rewound. When I released it, the clock resumed counting time from the earlier point, but my audio was still playing from the same position, as if it hadn’t been rewound. So now the clock didn’t match the audio. When I powered down, powered up, and unpaused, it began playing again from the earlier point, matching the rewound clock.

@tuanglen wrote:

My 8GB Clip+ has EXACTLY the same symptoms. It will occasionally just randomly shut off despite a fully charged battery.


Have the same problems. My Clip+ randomly reboots/turns off. After I turn it on again it begins to play from the time, where player was last time successfully turned off.

I have 01.02.13  firmware.

The problem with losing the ability to pause a podcast comes when you press the play button while the device is still booting up. Just wait a second or two longer before pressing play after switching the device on and you won’t run into the problem. It is a bug and is easy to reproduce.

I also have had the occasional random shutdown while hearing podcasts. I am however not quite sure if this is a bug or just the Sleep function doing its job. My current guess would be that the Sleep function might survive a power down instead of getting reset to “off” or something like that and then it triggers when you don’t expect it to. As the device is doing a clean shutdown and not just turning of at random this doesn’t look like a battery problem or anything like that.

I’ll try waiting longer before I press play on startup. That may well be triggering the “can’t pause” mode in my case. If so, it’s certainly a bug but, with added inconvenience every time I start or restart the device, I can at least work around it (unless something else also causes it).

For the spontaneous power off, though, it isn’t a remnant of my use of sleep mode, because I never use the sleep feature. It could of course be that somehow the device slips accidentally into sleep mode, then shuts itself off on a timer. Maybe pressing play during startup can turn on sleep mode, too.

Today Clip+ suddenly turned off again. I have to press power button for 15 seconds to turn it on again :frowning:

I am in good company here: I was led to believe that my Clip + was defective and I got a replacement under warranty, but the problems continued with the new device which also exhibited unintended shut downs and failure to pause podcasts.

Since upgrading to the latest firmware (01.02.13), I have not experienced unexplained shut downs (which used to happen when listening to the radio too). The pause problem persists and the workaround I use is to navigate out of the currently playing track (usually a podcast), select the same one and choose “resume playing”. After that, the pause function works again.

One of the posts above suggests not pressing play before the device has properly booted. I do that all the time and will be careful not to do so from now on. Hopefully that will solve my problem.

Me too, same problem in 2 devices (purple, 4G) my red one that was stolen last year did not do either of these things.  When it continues playing, despite pause being pressed it shows the pause icon on the screen, but continues to play.  I only use it for audiobooks.  Once it does it (turn off, or fail to pause) and has been off and turned back on, it will not do it again till another day or session.  I would like to wipe the software completely and start over, it says all the updates are good and so won’t replace what is already on there.   I will try waiting longer to push play, but I know that when it turns itself off I am pretty impatient to restart and press play before it is ready, but it doesn’t do it then.

I tried the reboot (20 sec power button held down) and waiting several seconds after power on to start playing and have not had a problem since.  A little annoying, but workable.

I have had both of the issues mentioned by others (random shut-offs and inability to pause), but the FAR more annoying thing I have been dealing with is something I didn’t notice in anyone else’s post.  I use my Clip+ primarily for audiobooks while driving, so I play for long periods and then power down or pause and let it time out on its own (so I can pick up where I left off next time I’m in the car).  A few times lately, I couldn’t get it to resume playing.  It shows that it’s playing, even though the counter doesn’t advance.  At first, if I paused & restarted a couple of times, or turned it off & back on, it would restart.  This morning, though, I tried everything possible and nothing worked.  I’m going to reset it when I get back in the car & see if that helps, but if it’s something wrong with the player I’d rather return it sooner than later.  From everyone else’s complaints, though, it sounds like an inherent glitch, and not something wrong with mine.

Try reloading or updating the firmware. Use the Manual method in the firmware thread among the top threads.