4GB Clip won't charge and overheats

SORRY about the errant posts. Ok, to I have had my CLIP for about a week. Great price from Amazon. My desktop PC would not recognize the unit so I went to the wife’s laptop which instantly recognized it. Loaded her up with about 500 songs, fully charged it. Worked great…sounded great. Yesterday the battery drained so I hooked it up via provided USB cable and the darn thing started acting wonky. Would not take a charge or turn on for more than a few seconds and really felt warm to the touch. Tried several times on several different computers with the same result. Per advice on this forum I tried my Motorola bluetooth AC charger with the same size USB. Looked good until the same problem with the unit heating up. I searched this forum for the same overheating problem and could not find a similar post, although it seems many have had problems with the CLIP freezing up and not charging properly. Should I just get it replaced or am I missing something.?

Try resetting the Sansa by sliding the power switch to the On position, and hold the switch in that position for about 10 seconds, then release.  This performs a soft reset on the device.

Then plug in and see if you have a happy rolling battery icon.

Bob  :smileyvery-happy:

Based on what I have read on this forum, I have already tried this. The problem is the battery doesn’t seem to take even enough charge to power up. I think it’s probably cooked based on the heat produced when trying to charge it. I am going to try and get a replacement unit that hopefully will not have the same issue b/c I really liked this player for the short time it worked.

If the Clip is still within the vendor’s return period, this route is the easiest.  Beyond this, the Clip is warranted against snafus for one year.  Contact 1-866-SANDISK, and they’ll fix you up!

Bob  :smileyvery-happy: