3rd Revision: iTunes Playlist to Clip (Mac/OS X) script

Just signed up to say thank you Kazwan!  Your script has been a great help to me as I own both a Fuze and Clip - it works perfectly on both.  Good work!

jamiemutley -

Ditto my response to Mandapandapop, previous. Thanks for the feedback.


I was very happy when I found your script, but the playlist is shown empty on my Sansa Clip.

Could that be due to the fact that I have iTunes 9?

The script is nicely shown in iTunes and seems to work perfectly. The songs are copied and arranged in separate folders according to the artists.

But when I access the playlist on the Sansa Clip, it appears empty.

Any idea why?

I have read other comments in this thread and I have looked for hidden files, but didn’t find any.

braut2 -

Hmmm, I’m starting to get a bad feeling. Another person in a private email said the script “worked like a charm” but he received an error message during its execution. He too is running iTunes 9.

So, I (relucantly, I personally don’t want every new version of iTunes) installed iTunes 9 on a backup system, tested it and it worked as always.

However, you may have the difference the other individual had; he was running OSX 10.5.8, and I am running 10.4.11 (Tiger).

As I told the other individual, if you want to help me out here you can do two things. First, email the XML file created for the playlist that did not work. You can do this in iTunes with File:Library:Export Playlist and export as XML. You can also email the .m3u file created on the Clip.

I can analyze those files and try to discover a clue to the problem.

It’s up to you if you want to help me resolve the issue. Send the email to the address you find in the download Readme file.

I’m guessing Apple would like to make it harder and harder for any other device than the iPod to work with iTunes. Those devious, little, bas…

Good news, for those interested.

Apparently a bit of a false alarm from braut2; just an oversight in using the script.

Reports to me that it seems to be working fine, though a potential (very minor) bug was brought to my attention in the process of investigating the problem.

Which I plan to fix (and perhaps less than 1% of users will ever know the difference).

Thanks very much for this script. I downloaded and ran it with Mac OS 10.5.8 and iTunes 9 (following the “read me” instructions exactly) and it worked beautifully. Going out now to walk the 100 lb lab with my playlist. Thank you!

Message Edited by jcdb on 10-15-2009 03:14 PM

Can someone email me the script? The web site seems to be down. alansky at gmail.com  thank you!

kalansky -

Did not know about this! And, naturally not real happy with my domain server folks at the moment. Not likeI personally check this on a regular basis.

As I type they are “sending a screen capture” of the fun Internal Server Error msg you are seeing to some tech support person and are giving me a “ticket number”.

Hopefully they will resolve the problem quickly (they did some platform overhauls Oct 16. that I’m guessing have caused some spits and sputters here and there).

OK. I have my “ticket #”.  I’ll post here when I get the email from them that the problem has been resolved.

I would prefer that people download from my site, but if you can’t wait, then you can’t wait.

Glad that you posted here though, as I likely would not have discovered this problem on my own for some time.

Running on Snow Leapord, iTunes 9.0.1.

The latest script executes fine, but when I bring up the playlist in the clip it appears to be blank. Here is the first cut of the playlist it created:

Spencer Strand\Turn It Up Lay It Down vol.I\01 Seinfunk.mp3
Spencer Strand\Turn It Up Lay It Down vol.I\02 Gaddzooks.mp3
Spencer Strand\Turn It Up Lay It Down vol.I\03 Octifunkdisco.mp3
#EXTINF:167,Hard Workin’ JB Groove
Spencer Strand\Turn It Up Lay It Down vol.I\04 Hard Workin’ JB Groove.mp3
Spencer Strand\Turn It Up Lay It Down vol.I\05 Zepthing.mp3
Spencer Strand\Turn It Up Lay It Down vol.I\06 Rock’n.mp3

The directory paths look correct (if you assume MUSIC is the root). I have reset the Clip, but that did not help. Any ideas what I may have done wrong?

– bk

bkearney -

If the text you’ve shown is just a piece of the total M3U file (I noticed the last entry is not followed by path information), then your problem might be that you, for some reason, did not let the script put the M3U file in the default location, which is also the Clip MUSIC folder. That is where you should find it.

Otherwise email me direct (see the Readme with the download) and I will investigate further. You will need to email me both the M3U file created and the XML file you can get from iTunes for the playlist in question. Just go to File:Library:Export Playlist  

For those interested in my iTunes Playlist to Clip script (main post is here), my download site problem has been resovled by my domain server folks. Also, see the announcement here (post title is New Revision of iTunes Playlist to Clip script) regarding the latest revision to the script.

Message Edited by kwanzan on 10-21-2009 11:57 AM


Thank you. I had placed the playlist as a peer to MUSIC, not in the music directory. Once I moved it down to MUSIC it works fine. Thank you for you help!

– bk

Thank you! You’ve taken me from gathering all my packaging materials to return the Fuze to listening to my playlist as I type this.

It’ll take a little bit more time before I get past the rather creative definition of it being ‘mac compatible,’ since I’m enough of an apple person to equate that with working out of the box. But this program is a great, great thing. Thank you again!

teawaste -

Always nice to get feedback. Glad the Fuze is now a viable music device for your Mac system.

FYI, (and for others), I’ve been working on a few fixes to my script (some general improvements to run-time feedback, and also a tiny bug in the way it currently checks for available space on the Clip as it transfers songs. Also, it has been reported to me that under Snow Leopard my .scpt file icon is not appearing in the unpackaged DMG and I am working on fixing that.

I have a list of folks I will email directly when I have the revision and new package complete and will email them directly. You are on that  list as I’m sure you know why.

For those not on that list, my original post on this forum is where I always post updates, as well as a separate post to “announce” a new revision. Since this is not an official business venture, I have not put the time into writing Web software to gather email addresses and create a database of users who have downloaded, so I do not have, at this time, a truly effective way of reaching back to those who have downloaded my software in the distant past. I just have to hope they look here for updates, or periodically check my website. Bit off topic, sorry.

Thanks again, teawaste for your feedback. 

Hi, everyone. Kwanzan & people, plz help me!

I installed script in the Script folder and Script icon was shown on the toolbar of iTunes. 

I’ve already send music files into Sanca Clip, it works fine.

Usually, I don’t keep music files in my Macbook, so I put same files in iTunes’s library of my MB and made Playlist.

Click script “iTunes to Clip”, then follow the navigation, script ask me to name .m3u file and place it “MUSIC” by default.

then click “Save”,  after a window shown “Processing Playlist Hits begins now. Turn off status reporting?”, click yes.

after this, this message is shown.  “Track Format Not Supported!!”.After that m3u file is made but file include date only “#EXTM3U”.

 All files are already convert to AAC to MP3 before I use sansa.

Are there any way to solve this?

My system is

OS X  10.4.11

iTunes  7.7.1

Sansa’s firmware version is V02.01.32A

sorry my English.

Thank you!!

Message Edited by shirah-love on 01-08-2010 06:12 AM


Got the script. Great stuff! It appears to generate the .m3u file just fine. I’m having a problem, though. I’m not sure of it’s the script or the Clip. I have .mp3 files on the Clip, 147 tracks. I drag them to an iTunes playlist and shuffle it in iTunes. The playlist in iTunes has 147 tracks. Then I run the script, and it appears to work perfectly. I end up with a .m3u file on the Clip. The .m3u file has 147 entries, and they’re in the same order as the shuffled playlist in iTunes. Perfect! :smiley:


Then I unplug the Clip and navigate to the playlist. I start it playing, and I see 001/123. In other words, the Clip is only “seeing” 123 of the 147 tracks in the playlist. Then, if I go to Music -> Play All, I see 001/147. So the Clip actually can see all 147 tracks. So either:

  1. there’s something wrong with the .m3u file, or

  2. the Clip isn’t interpreting the .m3u file correctly or otherwise has some problem with .m3u playlists.

BTW, I have done the steps of converting the id3 tags in iTunes, and no change.

Also I’ve looked at the tags of one of the tracks that is in the .m3u file but that doesn’t show up in the playlist on the Clip. They have no weird characters/accents/umlauts/etc.

Any idea what’s going on here?

Oxide -

Hmmm. Thanks for providing all the relevant info.

First, I will say I have likely not tested my script with a playlist comprised of that number of songs (purely for time convenience in testing). So there could be some weirdness happening that I have not tested for.

That said, we should probably continue this discussion off-thread. As a first step when I get these kinds of questions/problems the first thing I do is ask the person (you) to locate my email contact in your download (for my script) Readme file, and then email me your problematic m3u file. Quite often I will recognize an issue right away when I look at that file.

So, please send me the file, because if I have software bugs, I want to know about them.

You’ve got mail! :slight_smile:

For those of you who may have downloaded my iTunes to Clip script, I revised the script
to address an issue that has been brought to my attention recently by
a forum member. The revised script is now available at the download site
provided in my original post, i.e., here: http://sharefiles.quietlakephoto.com/scripts/itunes2clip_download.html

A user emailed me to bring to my attention the
fact that the Copy window of my script will assume the foreground
during execution and will repeat this for every track copied from a
playlist. Even though the user might regain the foreground by working
with another application or process during the execution of my script,
the Copy will then take it back, requiring the user to constantly
re-touch their app. Very annoying if you want to interact with another
app or process while my script is executing/running.

Fortunately, an easy fix. I now show the Copy window only on the first
copied track, just so the user will know where it is should they want
to return to it for any reason.

Hi, I nedd help, just made the script folder and got the icon in the Itunes menu bar but when I try to copy a playlist I get this message

could not find your sansa clip drive for saving the play list!!!

what to do