32gb ultra micro sd and apple products

Let me start by saying I’m not very savvy with any of this, but let me tell you what I can.

I purchased an SJcam4000 HD action camera and followed the directions on its use.  Formatted the card in the camera and took some video and pictures just goofing around.  I then tried to import them to my iPad and received the message that there wasn’t any photos to import.  Tried to then import them to the wife’s MacBook and got the message saying the photos don’t match the download criteria.

I formatted another card in the MacBook and then took movies and pics with the camera.  Same result as before.  I removed the SD card from my phone (android) and inserted the card from the camera.  All the photos were there but no video.

Is this an issue with the format the camera is writing in or the devices?

Thanks in advance


which format is being used by the camera to record video? maybe it is one that the software or the mac cannot support so in that case it is not detected to import it?

you can check with another pc even windows to see if there the video is visible and can copy the video from the card to the pc

I checked and mov is the format for the video


in that case did you tried the card on another computer to see if the same happens there? maybe its an issue with your computer