32GB Class 10 Micro SD card - unexpectedly removed in Android

Im having exactly the same problem on my galaxy s4. Card is getting unexpectedly removed on its own.

Im using 32gb class10 card by sandisk.

yup, happened to mine S4 which bought for only 1 week, what is the problem exactly?

+1 - for the problem on Samsung Galaxy S4

@kh1 wrote:

yup, happened to mine S4 which bought for only 1 week, what is the problem exactly?

Check with Samsung. Apparantly their phones are doing something that kills the cards. And it’s not only SanDisk cards that are affected.

I have same problem. My phone is ZTE Blade 3, in Czech republic’s distribution is called ZTE Skate Pro. Any solution? Thank you.

Same problem with the same card bought back in December within my S2.

This is truly unacceptable - I will be requesting an RMA now, but do not know if we can trust Sandisk memory cards…

Hi All

There has been reported issues of some of the older 32GB MicroSD HC cards in Samsung devices.

I have the same fault on a 32GB Micro SD HC Class 4

Samsung advised me to call Sandisk and Sandisk advised their newer 32gb cards have a newer format and will cure the issue. Will be recieving a new one under RMA in the next 7 days.

Give them a call guys (its not about needing Class 10), its a known defect

All the Best


Glad to know I’m not alone! I have been blaming my phone for the issue, thinking it was the “remanfactured” phone I bought, but I get messages like “Removed SD card” “Blank SD Card” etc and I switched external SD cards now, and so far no message, esp the consistent “Media Scanning” the device was doing. 

I am writing the company tomorrow and see if I can get a replacement or refund. I paid 19 bucks for this 32gb card, thinking it was a better class card, and now have a 4gb class 4 card in now with not a single error or issue. Come on SanDisk, you are supposed to be the reliable ones. Don’t start falling down hill!!!

Can anyone let me know if they have recieved a refund or replacement, and if the replacement was better? 

I bought the SanDisk 32gb class 10 micro sd card in October which caused problems in my droid x which, after reading the forums, is too large of a card storage-wise, so I suppose it was my fault for not checking for compatibility.  Just got the Galaxy S4 less than 2 weeks ago and I already got the error message, tried restarting and remounting which did not help.  I also tried using the card reader to try to recover the data onto my laptop and it wouldn’t read the card.  I lost baby pictures among other pics from this past week’s vacation so to put it mildly, it am very displeased!  So there is no way to get this data back? 

I also have a SanDisk 32mg class 4, thought it might have worked for the droid x, but did not.  I’m concerned after what some have said on this forum that this may have problems also.

I will be calling SanDisk for “replacement”.

I bought mine in October too, during the Amazon sale. It’s very disappointing, you might be able to get a program online to recover your photos, I had one on Windows but it brought back pixelated/scrambled photos. My phone does support up to 32gb card that’s why I bought it, but so far without the card the phone has been running really well. 

I think it’s the 32gb Class 10 SD cards, they are just not good. 

I have an LG optimus L9 (Great phone BTW) and i have the same problem, I just bought a 32GB ultra and when i do a speed test using the sandisk app on my andriod, I get the same speed as my:manfrustrated: wife gets with her class 4 16GB sandisk card…

Is the problem my card or the phone.

Greg, it’s the card. They are faulty. Call or chat with SanDisk and see if you can get a new one or a refund. 

Surprised that more folk haven’t voted for your post - the internet is littered with complaints about this issue and little evidence that anyone (including SanDisk) have solved.

I see a recent claim on a YouTube clip from 28 May 2013 (SD Card Unexpectedly Removed Finally Solved that problem caused by Bishal Sarmah) that the problem is caused by a Virus…Really?!? In the vain hope that it would fix the problem, I’ve tried it - NO JOY!

Your post filled me with hope untill I checked my 32gb card and found it is C4 :-/
I have a Galaxy S2 whi h was the most awesome piece of equipment ever until Samsung “upgraded” the OS since then it has had constant shutdowns and battery burn related to the “unavailable” sd card issue. Any other tips?

You might want to try this to save your data , It works for me when my SD card wasn’t reading from any device …Best of luck!


I have a 32gb class 10 also that has the me problem when i used it on a SAMSUNG S4 and a tablet which is an ANDROID 4.1.1 but  when i used it on my SAMSUNG galaxy mini which a GINGERBREAD 2.3.4 i donot encounter the same issues…  i will try it on a another samsung ace later if it will have the same issues…

 does this mean that it is a problem with android jellybean???


Have you asked _ Samsung _ the same question? :confounded:

Three of my family members have Samsung Galaxy S III phones with SanDisk 32GB Class 10 cards. I seem to have managed to find a card that worked in my phone. There was one recent glitch,* but otherwise fine. [*The glitch was not necessarily card related althogh the word card was mentioned in the error message.]  I do not recall initial problems, but really do not remember. My daughter has intermittent problems after I replaced a card that just did not work. The second card in my wife’s phone seems to be working.

I have been reading about this problem, which is how I found this thread, and there seem to be variables between the card, the Samsung Galaxy S III phone, and the version of Android operating system, specifically which version of Jelly Bean has been implemented in the device. Although SanDisk cards have often been involved, there also have been other brands.

In the case of the bad San Disk 32 GB Class 10 card in my daughter’s phone, it could have been damaged by a combination of the operating system and the phone. However, I could not read the card in a computer. That implies bad card, but is not definitive for at least two reasons. One it could have been damaged as by the phone or its OS, beyond the computer’s ability to access it or I could have failed to consider all the ways to get it to be recognized by the computer. At least one, and probably two of the cards failed inititally, so it was not some long term damage.

Although anything is possible since no one has conclusively identified the problem or problems, I do not really consider the computers card reader  itself to be a variable because it has read other cards and I also tried the bad card on another computer.

I do not blame any paricular manufacturer or software, but I do wish I saw more efforts to figure out why this is occuring.

I bought 16GB Ultra aroung a month back and have been facing this issue since first day.

I used two smartphones of different brands to verify whether this was the card or phone.

When I sent this card to service center, they returned it back after testing for aroung 30 min saying it is perfect.

This issue is not predictable and they can’t test just for 30 min for an issue which happens once every day in my case.

I hope SanDisk does something else I will loose my confidence in this brand and will refrain from buying anything in future, will even advice my friends to stay away from this.