32GB Class 10 Micro SD card - unexpectedly removed in Android

Hi eduncan911and all,

This makes sense and I’am happy to have found an evplanation. I have bought my 32G micro sdhc card in mid Decembre 2012 and about 2 weeks ago it started with the problems about ‘unexpected removed by android’. It ended up in drainig the battery of my galaxy s2 drastically until removing the card.

Altough I know how to go on further now, I’m unhappy with this all. Have you ever seen the promotion and the package of the product? Sandisc literally suggest to use it espexially with Android devices. Just look at


I feel dissapointed because this doesn’t match at all with the technical workaround described in your post. Or your words are pure nonsense (I don’t think so) or Sandisc wants to sell inadequate products for the promotion and description delivered for the product…

Looking around same forums (I did researches for several hours in 4 different languages) I see many users posting the same problem. This topic does tear the reputation od Sandisc.

@ Sandisc

Is there any proactive way to deal this problem from your side or will you just wait for ± 80 % of the users claiming guarantee and never buy your products again? We want a product that fits our need (as promised in promotion)  and a hassle-free change of product.

1 Like

Older phones, like the HTC Hero I have (Android 2.1), didn’t have an issue with Class 10.  Only newer phones seem to have this problem (just a guess, but the faster the hardware/OS, the more it holds the timeouts to their word?).  hehe.

Hi, I had this same issue with a Class 10 SanDisk Ultra 32GB microSD card, I bought it on October 2012 and used it happily in my Samsung Galaxy Note until February 2013 when I started facing this same problem, repeated messages that I had extracted the card until now when it is completely unreadable by either phone or computer.

I called SanDisk today and they said they would ship a replacement card, and denied that this is a specific problem with this card, said that millions of people use SanDisk cards successfully and only those who have problems write in forums for certain problems. Now I must take a picture of the card and send it to them, then I must destroy the card and they ship a replacement.

I hope this is not a general Class 10 problem… your explanation makes sense except for one point: why people (myself included) get to use the card happily for 3-4 months (approx) until it starts having problems? I had absolutely no problems before the time when I started getting the “card removed” messages. I don’t know about WP7, my experience is with Android 4.0.4 in my Galaxy Note 1 phone. I hope the replacement works.

Best and thanks for the info.

I had this same issue with a Class 10 SanDisk Ultra 32GB microSD card on my Galaxy S3.

my card seem no error after check by windows 7 utility but offen unexpectedly removed in Android.

I guess the problem issue because android has updated the os with patch, that why people (myself included) get to use the card happily for 3-4 months (approx) until it starts having problems.

i need the action from sandisk to fix this, it drain my battery to emty so fast.

This is happening on the Galaxy S4 as well. It’s unbelieveable how nowadays companies can sell worthless products that don’t work just to get the income. There is absolutely no recourse because the data on the card is irreplaceable. I was using the Class 10 SDHC Micro 32GB in my phone for 5 days. All of a sudden, it starts with the “card unexpectedly removed” error. Then it would unmount and mount continuously. I figured I’d at least get the data off by putting the card in my laptop. Nope. All I got was a “no drive” error, so everything’s gone.

SanDisk is a huge company so like most large companies today, they probably couldn’t care less, but I really hope they lose something as important to them as everyone using their products is. 

1 Like

it is strange that the only reports of this issue are with samsung phones. i ahve not seen anyone with any other manufacturer Android phones ever reporting this issue. that said if the card is not mounting even in the computer it will need to be replaced. Probably best to give sandisk support a ring 866-sandisk. 

Yes, and it’s strange the way they answer, as if denying that anything is going wrong. When I called Sandisk they made an effort to make me understand that this is not a widespread problem, just some people with problems that complain in a forum. There is clearly a problem with the Ultra 32g card mostly in Samsung phones, people, talk with Samsung and fix it! We are losing tons of precious info!

Im having exactly the same problem on my galaxy s4. Card is getting unexpectedly removed on its own.

Im using 32gb class10 card by sandisk.

yup, happened to mine S4 which bought for only 1 week, what is the problem exactly?

+1 - for the problem on Samsung Galaxy S4

@kh1 wrote:

yup, happened to mine S4 which bought for only 1 week, what is the problem exactly?

Check with Samsung. Apparantly their phones are doing something that kills the cards. And it’s not only SanDisk cards that are affected.

I have same problem. My phone is ZTE Blade 3, in Czech republic’s distribution is called ZTE Skate Pro. Any solution? Thank you.

Same problem with the same card bought back in December within my S2.

This is truly unacceptable - I will be requesting an RMA now, but do not know if we can trust Sandisk memory cards…

Hi All

There has been reported issues of some of the older 32GB MicroSD HC cards in Samsung devices.

I have the same fault on a 32GB Micro SD HC Class 4

Samsung advised me to call Sandisk and Sandisk advised their newer 32gb cards have a newer format and will cure the issue. Will be recieving a new one under RMA in the next 7 days.

Give them a call guys (its not about needing Class 10), its a known defect

All the Best


Glad to know I’m not alone! I have been blaming my phone for the issue, thinking it was the “remanfactured” phone I bought, but I get messages like “Removed SD card” “Blank SD Card” etc and I switched external SD cards now, and so far no message, esp the consistent “Media Scanning” the device was doing. 

I am writing the company tomorrow and see if I can get a replacement or refund. I paid 19 bucks for this 32gb card, thinking it was a better class card, and now have a 4gb class 4 card in now with not a single error or issue. Come on SanDisk, you are supposed to be the reliable ones. Don’t start falling down hill!!!

Can anyone let me know if they have recieved a refund or replacement, and if the replacement was better? 

I bought the SanDisk 32gb class 10 micro sd card in October which caused problems in my droid x which, after reading the forums, is too large of a card storage-wise, so I suppose it was my fault for not checking for compatibility.  Just got the Galaxy S4 less than 2 weeks ago and I already got the error message, tried restarting and remounting which did not help.  I also tried using the card reader to try to recover the data onto my laptop and it wouldn’t read the card.  I lost baby pictures among other pics from this past week’s vacation so to put it mildly, it am very displeased!  So there is no way to get this data back? 

I also have a SanDisk 32mg class 4, thought it might have worked for the droid x, but did not.  I’m concerned after what some have said on this forum that this may have problems also.

I will be calling SanDisk for “replacement”.

I bought mine in October too, during the Amazon sale. It’s very disappointing, you might be able to get a program online to recover your photos, I had one on Windows but it brought back pixelated/scrambled photos. My phone does support up to 32gb card that’s why I bought it, but so far without the card the phone has been running really well. 

I think it’s the 32gb Class 10 SD cards, they are just not good. 

I have an LG optimus L9 (Great phone BTW) and i have the same problem, I just bought a 32GB ultra and when i do a speed test using the sandisk app on my andriod, I get the same speed as my:manfrustrated: wife gets with her class 4 16GB sandisk card…

Is the problem my card or the phone.

Greg, it’s the card. They are faulty. Call or chat with SanDisk and see if you can get a new one or a refund. 

Surprised that more folk haven’t voted for your post - the internet is littered with complaints about this issue and little evidence that anyone (including SanDisk) have solved.

I see a recent claim on a YouTube clip from 28 May 2013 (SD Card Unexpectedly Removed Finally Solved that problem caused by Bishal Sarmah) that the problem is caused by a Virus…Really?!? In the vain hope that it would fix the problem, I’ve tried it - NO JOY!