2GB microSD not responding

Can you send it to me as well?  cli7554 (at) gmail.com

Hi. If it’s not too much trouble, I would like to roll back my firmware as well. I have had a 2GB MicroSD sitting here not being used when I bought it spiffically for my Sansa Express.

In case you have trouble finding my email, it’s stormdrain109 -(at)- yahoo -(dot)- com.

Thanks to anyone who can help me use my player.

Hi - not sure if you’ve sent the rollback out yet, but I haven’t got it (andyandbuster(at)yahoo(dot)com(dot)au).

Please don’t read this as bugging you - you are doing me a big favour and if you haven’t got around to it yet then no worries - just didn’t want to miss out if you thought you’d already sent it. 

Thanks again!

I did send it out once, but it bounced back the e-mail for whatever reason…  I’ll try again.

Nope, still not sending.  Says it is trying to forward from the e-mail you gave me to bridie.okeefe(at)gmail(dot)com and that address is rejecting it.  My gmail account did the same thing when Sandisk was trying to send to me.

Hmm, that’s weird … can you try mickycm(at)yahoo(dot)com

thanks and sorry for the hassle!

Please. Upload it on rapidshare and give us a link.

Thx in adv.


Just wanted to thank you, prozema! That rollback did the trick!

Your welcome… at least we finally got an answer to a problem that should have never existed.

@prozema wrote:

Thank you prozema. This has allowed me to use my Kingston 2GB card, and I haven’t found any problems with this firmware. I switched from 01.01.01P2 (pacific rim) and have actually noticed some extra options - most interesting is one allowing higher volume levels than usual.

The way in which Sandisk has responded to this ‘bug’ is unfortunate. Sandisk are doing a very good job in making this problem seem intentional…

Message Edited by nelson on 11-26-2007 05:01 AM


I really appreciate people that do not think only about their selves. I was myself actually ordering the sandisk microsd card, but decided to read this thread to the end, and you, prozema, had the solution.

The company Clas Ohlson (which is really known around scandinavian countries) I work for sells these Sansa Express 1GB Mp3-players, and I have seen many disappointed customers because of this memory card problem. Now prozema, you can feel very proud about yourself, because this older firmware update that you got from Sandisk will save christmas for tens, maybe hundreds of our customers (we sell these players about 300 per day around Norway, Sweden and Finland).

Thank You prozema and Merry Christmas everyone,

Johannes from Finland

You are very welcome everyone.  I know how disappointing it is to purchase a product and then not have it function the way that it is supposed to (especially at the fault of the manufacturer).  Merry Christmas everyone :wink:

I’ll add my voice to the chorus just because I don’t want to be a grab-and-runner.  We’re strangers, but we really appreciate when someone helps us out and it’s nice to be acknowledged.  Thanks.

Ok, I’ve run the updater from prozema, the firmware version under System Info now shows as 01.00.15F2… and I still get the same results when inserting a 2gb microSD card:  Sluggish menu response and no indication of greater capacity or external storage in Windows. (Note: same results with 2 different cards, a “pqi” brand and an actual SanDisk brand)

What exactly is supposed to happen when a card is inserted?  Does the sansa screen acknowledge this somehow?  Should I only insert/remove the card when power is off?

I have an RMA pending for this since in the midst of fiddling with it this morning, it got to the point where the computer wouldn’t acknowledge the presence of the player when plugged into USB.  Further fiddling after the call resulted in getting it recognized as a “Player Recovery Device Class”, which at least let me run the firmware updater again.  So I have it back to the condition it was in before, functional, but still without expansion capability.

Should I just RMA the thing now and get a “fresh” device, or hope that a new firmware is actually released within the next 10 days (during which the RMA shipping label is valid) that will actually fix the problem?

When I insert my card, it shows on the screen that it is updating the database and not to remove the card while it is doing that.  After that menu response time is not bad at all.  Also, I am able to insert or remove the card while the device is powered on.  You may have something wrong with your device other than the firmware so I would probably go ahead with the RMA.  I wouldn’t hold my breathe for Sandisk releasing another firmware update… they don’t seem to do it often at all.

If any of you guys still have problems with the microSd cards, you should update to the newest firmware 1.01.05 which fixes those problems along with boot up issues and SDHC support.  So update and see if things are working out for you.  As for me, it’s working great so far now.

How do you reformat the cards i have a 2gd micr sd from lexar?

@sugarbear7151 wrote:
How do you reformat the cards i have a 2gd micr sd from lexar?

Please open a new thread for your problem instead of reviving a year-old thread about an unrelated topic.