2GB microSD not responding

No joy. Bought a external card reader, formatted FAT 32. No change
in behavior. What a crock. No wonder people buy Ipods. My old
Rio Riot was better (also had lots of little fussy issues.)

I don’t think I am game to buy a Sandisk 2g microSD card to prove
it is Sandisk limitinng Sandisk players to only Sandisk memory cards.

Do not upgrade your player to a new firmware unless broken.

-r

Once I get my SE back from RMA, I’m gonna test to see if only Sandisk cards work on this thing.

On the another note,
is the c series having the same MSD problem?

I talked to Sandisk support on the phone today. Very professional,
they offered to RMA the player which I will eventually do (I bought
the mp3 player now because I needed one for travel.).

I tried to discover if Sandisk was actually aware of this issue
as a known bug, and that was not very clear in the end. A lot
of “I am just the phone tech guy what can I do but RMA it?”

The phone tech did say there would be a new update in a month
and that I should not update the new player. But the suggestion of
a update in a month could be just so much pleasant talk.

Clearly a problem with a large non-integrated manufacturer.
There are probably at least 4 entities involved, hardware design,
software design and they might or might not even work for Sandisk
(could be contract.) The Sandisk corporate, and of course sales and
marketing, and then the user support. And it is not like the tech on
phone can call down to the code developers and say “what’s up”.

And if it is in fact something about DRM, that if I have a subscription
service, and if it stored music on the microSD, I can remove the card
and then by hook or by crook get the music off the player and
remove the DRM protections. I would be curious if the player’s behavior
changed wrt to subscription services after the upgrade.

-r

Exchanged it at Best Buy.  Works just fine now.  But it does seem like a more recent Firmware Version… V1.00.15A2

I won’t update until Sandisk addresses this bug specifically.  This is very poor for a business to say “Upps Just RMA it”

How about REMOVING THE UPDATE FROM THEIR WEB SITE OR AT LEAST DOCUMENTING THE BUG!!!

As a software developer for both embedded products and PC products I can say this just makes my stomach turn everytime I think about it so I am going to save myself the stress and never return to this Forum or Sandisk’s site.  Good luck to everyone still up the creek!

I am noticing additional problems with 01.01.01A (might have been in 01.01.01 too.)

While copying songs in USB MSC mode today, a bunch of songs are Unknown Artist, Unknown
Album and song title is 01-Tea~1.mp3. Explain that. Earlier transfers are
fine. Either the filename or if the tags are too long or contain special character …
Rio Riot works with these files … Windows Media shows the right information … everything
but the Sandisk Express … if I mess with the MP3 is eventually fixes itself … I saw a
“no song” that fixed itself.

Eventually everyone ends up with an Ipod :frowning:

Interesting in Window Media 9 it was easy to edit the tags and get album information
on a song while it was playing, just right click, not in WM 11, have to be in library mode …
that is an improvement :wink:

V1.00.15A2, I think that is even a older version 01.01.01.

-r

I have the same problem. I bought 2GB microSD card. It worked fine for while until the battery of the player was completly drained. Since then the player cannot recognize the memory card.

Just bought my 1G Sensa Express from Singapore. They have thrown in a free 1G Sandisk MicroSD. So far it is working fine. After reading this forum, have decided not to install the firmware update. :)

broken_already wrote :-

>"While copying songs in USB MSC mode today, a bunch of songs are Unknown Artist, Unknown
>Album and song title is 01-Tea~1.mp3. Explain that. Earlier transfers are
>fine. Either the filename or if the tags are too long or contain special character …
>Rio Riot works with these files … Windows Media shows the right information … everything
>but the Sandisk Express … if I mess with the MP3 is eventually fixes itself … I saw a
>“no song” that fixed itself. "

Btw, what is USB MSC mode? So far I have use my Windows Explorer to directly write MP3 files into both the 1G internal and 1G external. Initially I also experiece the problems that you have mentioned below. What I did was to delete those files from Sensa Express. Pull it out and let it “rebuild the database”. Simultaneously, I use Windows Explorer to create the album title and title for my various files. Then I plug it back to my USB, copied the files back, and unplug it again to allow it to “rebuild the database”. Now it can show the songs by Album correctly.

Message Edited by ngcw on 09-02-2007 07:46 AM

Hmmm, I’ve got a 1GB SanDisk microSD from Best Buy and updated my Express.  Everything still works fine…  So far…  :slight_smile:

I just learned this the hard way.  Same story.  Kingston MicroSD.  Updated firmware.  Doesn’t work anymore.  Found this thread and it’s at least a month old.  Why is this firmware still available?!!  I am furious!  I bought this player for this very feature and after less than a week it doesn’t work and it was nothing I did but the manufacturer itself! 

This was on sale this week, so of course when I went to exchange it, they are all out of them.

Sandisk has made another unhappy customer.  Either fix the issue or allow us to regress it back to the old firmware.

Same boat as all the rest of you, bought a 2GB kingston … almost bought the sandisk 2GB but the kingston had free shipping ($1-2 cheaper) and I thought was a better brand.  Well I am going to mess around with it more to see if I can get lucky (maybe reformat a few time and hope the problem disappears).

>Btw, what is USB MSC mode?

USB can have different OS drivers. MTP which is a portable player specific driver that microsoft supplies
with Window Media Player 10 and 11, and “native” on Vista.

USB MSC is the standard USB mass storage driver (same that works with various thumb drives
and USB external drives.)

The Express will default to USB MSC when MTP is not available (or better put Windows will install
the MTP driver and it wins when the Express is installed unless you change the driver in
the windows hardware manager.

Wikipedia has some good introductions. Before MTP each portable device had its own driver.
Apple and Ipods use “Isync” over USB for example.

I was thinking back a few decades, about the rumor Sun Microsystems did not burn in test
their computers. Instead they let them fail in the field, and just ship new parts. I assume MP3
players don’t get a week of operation at elevated temperatures before final acceptance testing either :wink:

-r

I have finally found a solution to the problem described in my previous post. The trick is to change Express’ mode to MSC. Once the mode is changed to MSC windows will recognize SD memory card as an external drive. You will need to format it. After the format is finished, Express will recognize the card and you will be back in the game.
In order to change the mode to MSC follow the instructions below:

  • Click on the Start button and Select Settings. Then click on Control Panel. 
  • Double click System, and then select the Hardware tab. 
  • Click on Device manager. 
  • Click on the ‘+’ for Portable device and you will see “Insignia Video Player”. 
  • Right click and select “Update driver”.
  • A Hardware Update Window will open, Select “No, not this time” when windows asks to search for software.  Click next.  Check the “Install from a list or specific location” checkbox and then click next.
  • On the next screen select “Don’t Search. I will choose the driver to install”. 
  • Click next and then you will see a window showing two drivers that are compatible with your player.
  • To put the device into MSC mode select “USB Mass Storage Device” and click next. 
  • A finish installing driver will appear and your device will now appear as a hard drive on your system.

Hi James,

I have a Lexar 2GB. My mp3 player was working fine yesterday, all of my 300 songs were showing up on the screen. Came home to recharge and add some new songs, the expansion card icon would not show on my computer. Took a look at the mp3 player, the number of songs went down to 200. My son searched, formatted, etc. This morning I only had 200 songs. Came home to recharge plugged in the mp3 and still no expansion card icon showing. How do I get my card to show again???

I recently purchased a Sansa Express. I bought a pq1 microSD card to use in it. They play wouldn’t recognize it and I contacted SanDisk support. They said the MP3 player only supports SanDisk microSD cards right now. I can not believe that when using an industry standard such as microSD that they would do this!

I would have to pay 55 bucks or more for a SanDisk 2GB microSD when I bought another brand for $24.

This is part of the response I got back from SanDisk:
Please be informed that as of this moment that the player can only recognized SanDisk MicroSD cards. However, we are now making an update for the player in order for it to recognized other MicroSD cards.

I plan to return mine for a refund as this is unacceptable to me as a consumer. I would recommend that to anyone else that still has the chance.

Message Edited by thompsonmkt on 09-28-2007 10:44 AM

So I guess the answer is they don’t care, they are not going to tell you before you buy it about this problem, and they’ll fix it when they’re good and ready.

I found this funny,
My computer, installed my SE as a MSC when I plugged it in and after 4 seconds unplugged it and then replugged it in for the first time.
To switch back to MTP I just deleted the MSC drivers related to the SE and then plugged the SE back in w/o unplugging it and replugging it in.

Haha, it’s funny. But I’m using Vista so I’m not sure if this trick works for XP or such.

I tried a suggested fix - reformat to Fat16.  Still doesn’t recognize card and it total messes up playing songs - they skip as though the device is too busy indexing the card to play the song.  This whole problem occurred when I foolishly updated my firmware from 1.00.15A2 to 1.01.01A2.

Called the tech support line - their story is that Kingston uses a different controller and won’t work with the Express.  Ordered a Sandisk card with mini and std adaptors from Amazon ($30).  We’ll see if that fixes the problem.  I suppose I should be content with the base 2gb, but the slot is too irresistable.

Message Edited by pawinterks on 10-18-2007 11:33 PM

But it did work before the firmware upgrade.

Anyway, Staples had a sale week of Columbus Day and they had Sandisk brand for the same price I paid for Kingston, so I guess I’ll just use it in my camera with the adapter.

Sandisk 2GB SDMicro arrived.  Worked fine although I had an issue with the indexing not refreshing properly - showed songs and then wouldn’t play them.  Turning off and then on finally forced a full refresh and things seem to be working OK now.  If they could just get the resume feature to work correctly without having to resort to power off to save your place.