2GB MicroSD - Can't format

I have a 2GB MicroSD that I was using in a Samsung Saga Windows based mobile phone.  Since switching over to my Blackbery Curve (8830) I noticed it didn’t seem to be able to format or use the card.  If you tried letting the Curve “fix” it, it would just run and run and run, and never finish (and also kill my battery 3 times as fast).  There is data on the card and I can read it via my computer’s card reader.

Here’s what I have tried:

Formating it via my blackberry - fails

Formatting it via the card reader in my PC - fails

Putting the MicroSD into a SD adapter and trying to format it via my PC - fails

When I try to simply delete the existing files off of it (from PC), they disapear, but then reapear as soon as the card is re-inserted.

Tried running the winows error-checking tool - fails

Put it back in the old phone and tried to delete files - the reapear just like on my PC

Is there any hope or is it just time to cut my losses and throw it away?

Edit:  I just tried formating it from the cmd prompt and got a “Invalid media or Track 0 bad - disk unusable” error

Considering the price of 2GB cards ($2-$10 US), I’d just toss it & get another one.