16 GB class 2 card locks up Fuze

I just bought a 16 GB class 2 card (Polaroid) so I can put more movies on it, but when I try to play them, the player just hangs after 10 - 20 seconds, requiring a reset.   An 8 GB, class 4 Polaroid card works fine, so the obvious possibility is that the card is too slow.   Anyone ran into this  issue with other cards?  I would tend to think a 224x176 device doesn’t need that much of a bandwidth, but I may be wrong.


The class shouldn’t matter for anything but writing to the card, not reading from it.

Are you trying to play exactly the same file from the 8GB and 16GB (just to rule out the file itself as a problem)?

Have you formatted the bigger card to FAT32? \

Are you trying to play some humongous file?

Does the card and the files on it work in other things that can read it (cell phone, camera, USB card reader)?

Exact same files (copied from the 8GB card to to 16GB card); card was twice formatted, just to be sure; files are between 400 - 800 Meg (they all play fine from the 8GB card); and the card seems to work fine in the reader – haven’t tried other devices since most of the others can’t take SDHC cards.

Well, I’m baffled.

If you’re feeling patient, you might call 1-866-SANDISK, the real tech support, and ask them for ideas .

Since I have used a couple of Class 10 cards without any problem in said Fuze, and because the very same card had issues in a Velocity Cruuz T301 tablet (USB transfer only going with 1.1 speed)  I’m fairly certain that the lockup was somehow related to the card’s capability to transfer data.  Whether the card was defective, or class 2 is simply too slow, I do not know., and since I’m not going to buy anything slower than Class 10, I may not able to find that out. 

I have used Class 2 cards without problems, so I would suspect that particular card. You could test it with h2testw to see if it’s defective.


Have you tried using Check Disk? Also, have  you tried formatting with SD Formatter? Perhaps you could try removing the MTABLE.sys file from the Internal Memory (only visible in MSC mode)?