128gb SDXC micro sd problem! Help me find out what happened to it please!

Hi all, I’m new to the forums.

I’ll thoroughly go over what happened so someone will hopefully catch on some detail and tell me what mistake I made or what’s wrong with my sd card now. Please bear with me and thanks in advance to anyone who takes the time to read this, and/or respond.

About 2 weeks ago I purchased a Sandisk 128gb SDXC Class 10/UHS-1 micro sd for my windows tablet from eBay. When it arrived I inserted it to my device and transfered all non-program files to it (Music, Videos, Documents, Pictures, Folders) in order to save space on my tablet. I also set the micro sd to be the default location for downloads, pics, videos, etc. It all worked perfectly as expected.

A few days ago, on a relative’s connection, I was downloading music, surfing the web and what not. Then I wanted to download a game OST, and since I did not have winrar installed, I went ahead and installed it. Naturally, it was saved in my downloads’ folder (in the sd), and installed to my tablet. I went ahead and downloaded the OST (The site I got it from was safe, and this wasn’t piracy so no problems there.)

Well, here’s the hard part; after the download finished, I opened the rar file and I wasn’t able to view it, there was only an error message inside, no files. Tried to extract anyway… nothing. Downloaded it a second time, this time extracted to my tablet, and still nothing. Third try; I download to my tablet, Now I could see the files in the .rar file. So I extract to my tablet aswell, and I transfer the mp3’s to my sd. Now I try to play them on XBox Music app, though not all of them work. The ones that dont work gave me a “file format not compatible or corrupted” error message. I tried to play them on Windows Media Player, and it worked better than on the Xbox Music app.

In that moment I thought it was nothing, shrugged it off and let it go.

Then… I come back home, get curious with it again, and kept trying to play the music files. I think at this point I may have gotten a message for my external storage, to analyze and repair, so I accepted hoping for the best. After it was done, I didn’t think much of it so I played my other music I already had… Well turns out I couldn’t because the formats had changed to an unreadable format, along with all other files in my sd. It’s a shame 'cause I hadn’t backed it up. So I went ahead and deleted them. I think now it may have been related to that repair message.

The next day I found that OST again under my tablet’s downloads’ folder where I had last placed it after the third try of downloading it. I tried playing it directly from my tablet, and it worked perfectly. I put some other songs on my sd, and it was the same as the day before, sometimes they worked, but mostly errors of file corruption/wrong file format. I pasted the OST to the sd again and it got mostly error messages, though 2 songs worked (on and off with error messages when I tried to play them). So doing this i singled out the possibility that it was the OST the one with the problem, or my Music apps. The problem was with my micro sd.

This is where I’m at today: can’t stably play music from my sd, view pictures (it gives me an error of wrong file format), and I’m pretty sure I can’t open any other type of file format in a software without risking to get an error message.

I’m sure that if the card were formatted, it will go back to normal. My worry is though that formatting is useless if the same thing will happen again, so I came here for help or advice on what could have happened.


Also, directions on how to format this particular micro sd card are greatly appreciated!

1 Like

:smiley:   Hi Cowbait,

Dear member of SanDisk Community, welcome.

Please, analyze the following:

1-   Clean the pins of the card, and device slot, with isopropyl alcohol (or also, the medicinal).

2-   If still bad: test your card, microSDXC 128gb Class 10/UHS-1, in other laptops, directly to its port-card.

3-   If still bad: in Start / My Computer, on the card icon, click the right mouse button, and then click in Properties/Tools/Error Checking and Repair.

4-   If still bad: try formatting with (free): USB Flash SD Formatter 4.00, http://filecloud.io/jqtu1byc

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                             (Google translated)


Thanks for the quick reply, and excuse this late reply

I skipped step 1, as I literally got the micro sd out of the box and inserted it directly in my tablet. So there’s no chance that it needed its pins cleaned.

I followed with step 2, then at step 3 it seemed to work slightly better. Though I’d rather format for complete peace of mind.

What options should I select in the program you provided in order to format a sandisk 128gb SDXC Class 10/UHS-1 micro sd correctly?

Attending your response with most sincere gratitude.

:smiley:   Hi Cowbait,

Friend, is very simple:

Before starting, backup your content.

1-   In Drive (check, which is the letter of your card), is automatic.

2-   Size, is automatic.

3-   In Volumen Label, is to your liking.

4-   In Option, Format Type: Quick.

                        Format Size Adjustment: On.

5-   Format (exFAT), is automatic, because it is SDXC.

6-  Click in Format boton (below), and ready.


And then you tell us, what happened, please.

Regards, Alfred.                                                  (Google translated)

:smiley:    Hi Cowbait,

Friend, is very simple:

Before starting, backup your content.

1-   In Drive (check, which is the letter of your card), is automatic.

2-   In Size, is automatic.

3-   In Volumen Label, is to your liking.

4-   In Option, Format Type: Quick.

                        Format Size Adjustment: On.

5-   Format (exFAT), is automatic, because it is SDXC.

6-  Click in Format button (below), and ready.


And then you tell us, what happened, please.

Regards, Alfred.                                                  (Google translated)


I did as you suggested, but I got the following error. No idea why:


Could not format the Memory Card.
Either the drive or the Memory Card is not supported by this software.


Suggestions? Thanks again.

you may want to check the authenticity of the card. There is a program free to download called H2TestW. this will write to every sector of the card then go back and verify each write. If you see it start failing at, for example at 4GB and everything after that fails to verify, you likely have a fake card. 

Oh hello,

I actually looked into this H2TestW software, just to calm any doubts the sd were fake. These are the results I got:

Warning: Only 127498 of 127968 MByte tested.
The media is likely to be defective.
7.4 GByte OK (15662016 sectors)
117.0 GByte DATA LOST (245453888 sectors)
Details:6.2 MByte overwritten (12800 sectors)
0 KByte slightly changed (< 8 bit/sector, 0 sectors)
117.0 GByte corrupted (245441088 sectors)
800 KByte aliased memory (1600 sectors)
First error at offset: 0x0000000000000008
Expected: 0x0000000000000011
Found: 0x0000000000000000
H2testw version 1.3
Writing speed: 8.85 MByte/s
Reading speed: 6.49 MByte/s
H2testw v1.4

It says the memory card is corruped for the most part, I feared our suspicions could be true, but then I saw this, and figured that it’s impossible that its true size isn’t 128gb:


As can be seen, my sc is filled entirely by files, i looked inside and saw 127 files each 1gb, this is what that software does ofcourse. That’s all, at least i know it’s not fake, but certainly corrupted.

Anyone have any clue how to proceed?

:smiley:   Hi Cowbait,

If still bad, you can try with these apps portable (free), if it’s fake:

                                                                                                                           USB Flash DriveLetter,     http://filecloud.io/vgqzcdyh

                                                                                                                           USB Flash Deview,           http://filecloud.io/srp2hegw

If the above steps have not solved the problem, do not grieve more:

Contact SanDisk Technical Support who will replace the device, if it’s authentic and is within warranty.

Link: http://www.sandisk.com/about-sandisk/contact-us/

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                            (Google translated)

What is the password for the downloaded files? I’m unable to open them without a password. :frowning:

USB Flash FakeTest,        http://filecloud.io/n074g3x5

Hi Cowbait,

I came across your problem as I was searching some 128gb micro SDXC Cards and sadly may be able to help you. I was caught by SD micro disks on ebay which looked ok and good value and had similar problems.

They worked well at first and then as the card began to be filled up problems accessing photos and video clips started. Reformatting cleared it but again started going wrong as card filled up.

Took me quite a time of investigating before I found the problem.

I too used h2testw and I got similar results as you did but it still read as a 128gb card.

What happens in a fake is that it is a micro SD Card but of poor quality with only say 7Gb of memory as in your case but the headers have been altered to read 128Gb. The packageing is often of a good quality and looks genuine.

Then as you load up to 7Gb all works ok but after that any further downloads rolls back to the first area of the chip and overwrites your data corrupting it.

Your problem sounds exactly like what I was caught with and from EBAY. I wouldnt buy from them at all and would us a reputable store  (Like Currys PC World and have had no trouble since)

There are quite a bit of info about fake sd cards on the internet if you Google it.

Hope you get sorted out, but looks like you may have to find a good one some where else and put it to the test before useage.

Best Regards


I was able to format my card eventually…

I had searched and tried many ways including formatting via command prompt, formatting through my android and formatting through windows.

When trying to format with windows it would only give me the option to format it at 27gig.

In my android device it said that it successfully formatted and appeared to 64gig. however when connecting to USB in window it was still only 27gig. 

I finally got it to format using the DJI OSMO UHD camera whilst connected to a USB port with Windows 7. upon connecting to windows through the camera, windows prompted me to format it and it allowed the full 64gig to be formatted… That’s it!

I hope it helps someone out as I was almost going to try and get sandisk to replace it.

Good luck!

Hello respected ,
I have purchased 128gb 10class sd card i used it for 2 day but at last when i inserted in my phone its not showing any sd card…
After that i inserted this sd in Windows 7 PC with card reader but is aslo not showing…
What should i do?
Please reply me i am worring

Ok, here’s a thorough guide I made due to an issue I had that was resolved after this procedure. You will need a 4 GB usb stick, Rufus, the latest Ubuntu ISO file and SD Formatter.

Optimally, you want a direct SD slot to use via an SD adapter card. Avoid cheap USB adapters and use one that supports USB 3.0 or 3.1. A Kingston or SanDisk adapter (or one of similar quality) will likely be your best bet if you do not have an SD reader in your computer.

This will require you to reformat the SD card so backup any data beforehand if possible.

This is the Ubuntu Live method. Alternatively, you can use a Windows based application if it is able to create GPT partition tables for an SD card and skip straight to step 11.

  • Step 1: Get your hands on a 4 GB or larger USB stick. Alternatively you can burn a DVD if you have those resources available.
  • Step 2: Download the latest version of Ubuntu and Rufus.
  • Step 3: Launch rufus, select the ubuntu iso file and make sure you have the correct USB stick selected in case there are multiple plugged into your computer. Then run the procedure and it will create a bootable Ubuntu Live usb stick.
  • Step 4: With the boot-stick done, restart your computer and boot from the usb. UEFI or Legacy really doesn’t make much of a difference for this procedure but if UEFI is available, I would go with that one.
  • Step 5: After booting from the USB, select “Try Ubuntu” which should be the top option.
  • Step 6: Once Ubuntu has booted up, connect your microSD card with an adapter of your choice, USB or SD adapter directly into an SD slot.
  • Step 7: Click the bottom left icon that looks like a grid of squares, search for “Gparted” and run that application.
  • Step 8: In Gparted, find your SD reader or USB adapter and select it if it is not already selected.
  • Step 9: Press the Device dropdown menu and Create Partition Table.
  • Step 10: Select GPT and hit ok.
  • Step 11: Once it’s done, you can restart the computer by clicking the top right power icon in the user interface and from there restarting the machine.
  • Step 12: After you boot back into Windows, download and run SD Formatter, format your microSD card with exfat for smartphone use or NTFS if you have a Windows device you want to use it with.

A lot of steps, I know, but it did resolve my issue entirely. Hope this helps anyone out there experiencing SD card issues.

I have an old Dell laptop running Vista.  I got a 128 GB card from Amazon which would only format 24GB.  Thinking it might be related to the system or computer, I took my laptop to Best Buy and bought a new 128GB card.  In the parking lot, I tried the card in my laptop and it would only see 24 GB.  I took the card back in the store and had them place it in their computer’s SD slot and it saw around 120 GB available, making me think that it might be the machine/software and not the card causing the problem.

I am planning to use the cards in my other computer which is around 10 yo, but runninng Windows 7, which unfortunately is currently not working due to being about 30 feet from a lightning strike about three months ago.  I have determined the hard drives are good, but need a new motherboard.

If I still have problems, then I will try some of the above suggestions.