Showing results for 
Search instead for 
Do you mean 
Reply
Newbie
Zacks
Posts: 1
Registered: ‎12-29-2008
0

Sansa e280 Formatting Problem

I can't format my Sansa e280v1. I'm running on vista.

 

I know what the problem is, well, sorta. There is only one file on the mp3player I can't delete, and its the "My Music" folder from where I got lazy and drag/dropped my entire library. Its not the stock MUSIC folder, because I can delete that. Anyway, there is nothing inside the folder itself, but everytime I try to delete it, it says that "the device is not connected or has stopped working." When I try to manually format, it says "the device was unable to be formatted."

 

I browsed around a couple of forums previously and found a program called MoveOnBoot that could move and delete files during boot up before the system could stop it--like forcing the Sansa to drop the folder. Anyway, when I browsed the folder in MoveOnBoot, I found two folders that don't appear when I look through the normal explorer: GreenDay and Soundtrack. In the GreenDay folder is another folder for their International Superhits cd, and inside that is nothing but random filler file with a symbol for a name which I deleted through the MoveOnBoot program. Now I can't see either of those files anymore.

 

In the Soundtrack folder, there was another filler file like the one in the GreenDay folder, and another folder labled Soundtrack. In the other Soundtrack folder was the exact same thing, and it kept repeating and recreating itself. I couldn't delete either file with MoveOnBoot because it doesn't work on folders.  

 

Then I downloaded the Sansa Recovery Tool and tryed using it, but the instructions told me to put the device into recovery mode by holding the Right Button and the Volume Up Button, and there is no Volume Up Button on the e280. 

 

I've tried everything. I even did this command prompt thing ("chkdsk f:") but it just said it couldn't access volume or something...

 

Seriously, this is the most irritating thing I've ever dealt with. There are absolutely no files on the device, and when I browse the device itself, it has a bunch of empty folders and tries to play mp3s that aren't even on the device, and of course getting a "Bad Song Track" error in the process. 

 

What do I have to do? Buy a whole new Sansa? Probably won't after all of this. 

 

SanDisk Guru
AutobahnSHO
Posts: 1,395
Registered: ‎11-21-2007
0

Re: Sansa e280 Formatting Problem

I would start with disconnecting and powering off the Sansa, reboot the computer, and try it again.

Sometimes Vista does that to me with folders on the regular C: drive.

 

If that doesn't work, when you have the Sansa connected, you can right-click on the device and click "format". Search first for whether it should be formatted in FAT or FAT32.

-Will
-One e260, one e260v2, an e250R, Three e250s. www.rockbox.org
Two Clips.
SanDisk Guru
c1u31355
Posts: 2,871
Registered: ‎08-14-2007
0

Re: Sansa e280 Formatting Problem

[ Edited ]

The Sansa Recovery Tool is for the Sansa Connect. 

 

-------------------------

 

 

Formatting in FAT32 should work. However, out of curiosity, were you in MSC mode when you tried ChkDsk?

 

Did you have the exact right syntax? Run chkdsk E:/f (assuming your Sansa was drive E:--if not substitute letter).

 

Did you try the other way to ChkDsk, like so:

 

Double-click My Computer, and then right-click the hard disk that you want to check.
  1. Click Properties, and then click Tools.
  2. Under Error-checking, click Check Now. A dialog box that shows the Check disk options is displayed,
  3. Use one of the following procedures:
    • To run Chkdsk in read-only mode, click Start.
    • To repair errors without scanning the volume for bad sectors, select the Automatically fix file system errors check box, and then click Start.
    • To repair errors, locate bad sectors, and recover readable information, select the Scan for and attempt recovery of bad sectors check box, and then click Start.
    Note If one or more of the files on the hard disk are open, you will receive the following message:
    The disk check could not be performed because the disk check utility needs exclusive access to some Windows files on the disk. These files can be accessed by restarting Windows. Do you want to schedule the disk check to occur the next time you restart the computer?
    Click Yes to schedule the disk check, and then restart your computer to start the disk check.

 

Message Edited by c1u31355 on 12-29-2008 10:34 AM
Message Edited by c1u31355 on 12-29-2008 09:12 PM
Can't Connect? Other Problems? Answers
SanDisk Guru
Tapeworm
Posts: 15,112
Registered: ‎04-17-2008
0

Re: Sansa e280 Formatting Problem

I agree with C1u31355. It sounds like from what you said that your player is in MTP mode. It needs to be in MSC both to run the ChkDsk (but I believe it should be a forward slash:  /f, not \f), and subsequently format it.

 

I've tried formatting before when I had corrupted files and found I couldn't until I first repaired the files with ChkDsk. Then it would format OK and delete those bad files.

SanDisk Guru
neutron_bob
Posts: 5,819
Registered: ‎12-26-2007
0

Re: Sansa e280 Formatting Problem

Hey, it's a v1 device, there's a simple option to format:

 

Use Recovery Mode to format automatically.  Place a blank folder renamed sansa.fmt into the 16MB FORMAT partition.

 

NEVER USE THE WINDOWS FORMAT COMMAND ON THIS PARTITION, JUST THE FOLDER METHOD!

 

Bob  :smileyvery-happy:

Newbie
yessir
Posts: 1
Registered: ‎01-11-2011
0

Re: Sansa e280 Formatting Problem

me , my sansa is not being recognized by my computer

Newbie
katepre
Posts: 1
Registered: ‎01-29-2011
0

Re: Sansa e280 Formatting Problem

My Sansa e280 just the Blue ring is on. My computer doesn't recognize it.