Reply
Newbie
ExcPhoenix
Posts: 1
Registered: ‎01-21-2008
0

SanDisk does not show in my computer.

Hello,

I just bought my SanDisk, the model its e260v2.

The problem that I'm having, is that Windows is asking me for drivers to install the player (SanDisk e260v2), for which there is none, because this is a stand alone player (right?)

I cannot find the player in "My Computer", and when i go to Control Panel and I click on add hardware, it gives me [code 28] which is

The drivers for this device are not installed. 

I have read around this forums, and I have tried the following, I re-installed Windows Media Player, I have version 11, which is above the minimum requirements. I have tried to plug the device when its on and then when its off. Neither off these work. Also for the record I have Windows XP SP2. I also tried with the cd, however the cd seems or rather does nothing but install a Best Buy Music service (is this need it to use the player???)

My question is simple, I just want the player to be recognise by Windowns, and for it to show up in "My Computer".

Any suggestions are appreciated, thanks in advance.
SanDisk Professor
Mr_Moose
Posts: 766
Registered: ‎12-27-2007
0

Re: SanDisk does not show in my computer.

First, try different USB ports on your computer. If that doesn't do anything, check if the player can connect in MSC mode. If you can get your player to connect in MSC mode, then it may narrow it down the problem.
 
If your player is new, I assume you haven't had a chance to updated the firmware yet. You might have to set it to MSC mode manually. Attached is the step-by-step process, from the FAQ, on how to get into MSC mode manually.
 
 
For previous versions of firmware, Kudos to GorillaWatcher:

You can use the v2 as an MSC player.  Use the following procedure:

1. Set the 'hold' switch on.
2. Hold down the left arrow button.
3. While continuing to hold down the left arrow button, plug the USB cable into your computer.

The device should now be in MSC mode until you unplug it again.  This procedure has to be done every time you want to use the v2 in MSC mode as it automatically reverts back to MTP mode.