Reply
Newbie
Posts: 1
Registered: ‎02-06-2015

Sansa Fuze white screen

I've had my Sansa Fuze since Christmas of 2008 and since that time I've used it often and have not encountered any problems with it. On turning it on three days ago, I noticed it has a permanently white screen. It operates well in every other way, it can still play songs, all the buttons work and my computer says that the 'device is working properly', but navigating through songs is now effectively impossible. I've tried resetting it (holding the power bar up for 3 mins) and I'm pretty sure none of the firmware needs updating. I feel it may be a fault with the hardware, if this is the case, is there any way it can be fixed? I appreciate it's done pretty well to last over 6 years, but that's kind of the reason I want it fixed, as it's got quite a bit of sentimental value. As sad as it may sound, I can't imagine life on another MP3 player!

SanDisk Guru
Posts: 16,081
Registered: ‎04-17-2008

Re: Sansa Fuze white screen

While there are a number of discussions on this subject, there seems to be no clear-cut sure-fire fix for this. Feel free to read through them by following the link.

 

However, here is one suggestion that worked for at least 2 people. It's worth a shot. The only other thing you can try is updating (or manually re-applying if you already have the latest) the firmware.

 

Good luck!

 

 

 

 

 

Newbie
Posts: 11
Registered: ‎04-13-2015

Re: Sansa Fuze white screen

Do as I did, turn on and go to settings, then scroll to reformatting, press and it will do the rest. Mine had the white screen, computer would not recognize it, and it would not charge up, just would shut off. After the reformatting, all is good again. I did have to reload all my music as it all was erased somehow, but that  was no big deal. I was ready to throw my Fuze in the garbage, but it is all good again.

 

 

Bill

SanDisk Guru
Posts: 16,081
Registered: ‎04-17-2008

Re: Sansa Fuze white screen


billwild wrote:

Do as I did, turn on and go to settings, then scroll to reformatting, press and it will do the rest. Mine had the white screen, computer would not recognize it, and it would not charge up, just would shut off.

 


 

How did you do this if it had a white screen? Smiley Frustrated

Newbie
Posts: 20
Registered: ‎05-13-2014

Re: Sansa Fuze white screen

I feel the same way about mine. I washed the first one last year. It still works and I still use it, even though the screen backlight doesn't work. I've since bought a nearly mint 8GB one from a co-worker's daughter ($50), an e280 (also nice and in excellent condition with slip and a cable - $20), and just bought two more Fuzes for my boys (one good, one fair, $20 for the pair but no cables). The last three were craigslist acquisitions.

 

You'll also see them constantly on eBay. Last I looked, nice 4GB Fuzes were selling for about $50.

 

So, if you can't fix it, you certainly can replace it. It also might be worth mentioning that on the forum. There may be someone interested in yours for parts. (They can't have mine -- it still works!)

Newbie
Posts: 17
Registered: ‎08-05-2010

Re: Sansa Fuze white screen

[ Edited ]

Smiley Surprised Mine just did this but only with certain songs.They are .mp3 files but every time I try to play them the screen goes bright white. Takes about 20 seconds to shut off the player holding the power switch in the up position. They all though play fine in my computer. Interesting notation is that the ones causing this problem are LAME3.99.5 encoded.

 

I just tried to go into my EQ settings and got the same results! 

Seems the v.2 Fuze is going out on me! Smiley Mad

 

 

SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: Sansa Fuze white screen

If it's just one encoder causing the problem...don't use that version of LAME. Find an older one.

 

You didn't say what program you are using to encode or what bitrate either.

Newbie
Posts: 17
Registered: ‎08-05-2010

Re: Sansa Fuze white screen

So it just happened when I turned on the Fuze. It then got stuck at the logo and froze. I held up the power switch for about 30 seconds then it shut off. It's back to normal now. What causes this? I wasn't even playing anything. I have updated the firmware to 2.3.33. Smiley Surprised

SanDisk Guru
Posts: 16,081
Registered: ‎04-17-2008

Re: Sansa Fuze white screen


Sansabarr wrote:

So it just happened when I turned on the Fuze. It then got stuck at the logo and froze. I held up the power switch for about 30 seconds then it shut off. It's back to normal now. What causes this?


 

 

Gremlins

 

Smiley Tongue

Newbie
Posts: 17
Registered: ‎08-05-2010

Re: Sansa Fuze white screen

My guess would be poor QA at Sansa!

I use it on a daily basis so I hope it all holds together!