Reply
Newbie
Posts: 5
Registered: ‎04-28-2017

Playlist issue after Windows 10 Creators update

Hi

 

I hope you may be able to help with this issue.

 

I have had my Sansa Clip Zip 8GB player for several years now and it has always worked flawlessly - great little product. I like to play my files with the player in MTP mode.

 

When I want to add new albums or podcasts, I connect the Clip Zip to the PC (HP Envy Laptop, running Windows 10, and as of very recently the new Windows 10 Creators), add the files into the Music Folder, right click to Create Playlist, cut and paste the resultant .pla file into the Playlists folder, disconnect, then all good. I just go the Playlists on the device and choose what I want to hear.

 

That has worked flawlessly for several years, up until now. Yesterday I went to add some new music. Connected the Clip Zip as normal, added the files, no problem, created the playlist in the Music folder, no problem - the familiar .pla rectangle icon with the green arrow inside appeared as normal. But when I did the cut and paste, well cut was OK, but when I did pasted, nothing appeared in the Playlists folder.

 

All my old .pla files are still sitting there in the Playlists folder, with the familiar icon and working fine. But nothing new after I connected the Clip Zip to the PC yesterday.

 

OK, when I connected the Clip Zip first thing yesterday, I got a dialogue box up saying the Windows was 'Updating the Settings' on the Clip Zip. It took only a few seconds, but that seems likely to be the source of the problem. Connecting the Clip Zip to the PC very regularly in the past has never prompted and Update Settings process. And, it may be co-incidental, but this event has occurred since, very recently, I updated the PC for the new Windows 10 Creators.

 

I thought of resetting the Clip Zip to default settings, but all my old files, including old playlists are displaying and functioning fine. The Update Settings action yesterday has done something to the software in the Clip Zip such that it still recognises old .pla files, but not new ones. 

 

Am I best off restoring the Clip Zip to factory settings - to override whatever settings update Windows provided for me - or can anyone suggest a less drastic solution?

 

Appreciate any thoughts.

 

Cheers

SanDisk Guru
Posts: 16,049
Registered: ‎04-17-2008

Re: Playlist issue after Windows 10 Creators update

Restoring factory settings only erases your personal settings, like screen brightness, screen time on, etc. It does nothing else.

 

First thing I would do is check to see that the player is still in MTP mode. It may have been reset to Auto which means it can connect in either MTP or MSC mode. That can be problematic.

Newbie
Posts: 5
Registered: ‎04-28-2017

Re: Playlist issue after Windows 10 Creators update

Many thanks for getting back to me.

 

I checked, and it is still in MTP mode.  While I was in Settings, I looked through all the other options in System Settings, but couldn't see anything that could explain what happened.

 

While I was in settings, I just checked the version number as well - it's V01.01.21P.  I wonder if there might be an updated version, or a new driver to install that might be worth trying?

SanDisk Guru
Posts: 16,049
Registered: ‎04-17-2008

Re: Playlist issue after Windows 10 Creators update


PeterProg wrote:

 

While I was in settings, I just checked the version number as well - it's V01.01.21P.

 


That is the latest firmware version.

Newbie
Posts: 5
Registered: ‎04-28-2017

Re: Playlist issue after Windows 10 Creators update

I put the Clip Zip into MSC mode and tested it for viruses and malware - all clear there. Then I deleted some of the legacy playlists in the Playlists folder, recreated them from the original source files in the Music folder and tried to copy them across - nothing. Finally I deleted most of the files from the Music folder in case the number of files was getting too big for the hard drive, but nothing doing there either.

 

When I deleted all the files from the Clip Zip, the readout from Properties implied that around 1.5GB of the 8GB capacity was still in use, but maybe that is the operating system or firmware?

 

Anyway, just about out of options unless reinstalling the firmware might be worth a try (assuming that is possible)?

Newbie
Posts: 5
Registered: ‎04-28-2017

Re: Playlist issue after Windows 10 Creators update

Been researching on the Boards and I see instructions for installing a firmware update, but not for uninstalling and reinstalling the firmware version I already have.

 

If I just follow the instructions for installing the firmware - in MTP mode in my case - so drag and drop the extracted clpzV010121.bin file to the root of the Internal Memory folder, will that simply replace the existing firmware, or do I need to perform an 'uninstall' first?

 

If so, any advice on how to do that would be appreciated.

 

Thanks for the advice and suggestions to date.

SanDisk Guru
Posts: 16,049
Registered: ‎04-17-2008

Re: Playlist issue after Windows 10 Creators update

[ Edited ]

PeterProg wrote:

 

If I just follow the instructions for installing the firmware - in MTP mode in my case - so drag and drop the extracted clpzV010121.bin file to the root of the Internal Memory folder, will that simply replace the existing firmware?


Yes. But I usually advise having the player in MSC mode when doing this. You can always switch back to MTP mode but truthfully, unless you're listening to DRM-encrypted files you're better off in MSC mode.

Highlighted
Newbie
Posts: 5
Registered: ‎04-28-2017

Re: Playlist issue after Windows 10 Creators update

Many thanks for the advice.  I successfully re-installed the firmware, in MSC mode.  Then adjusted back into MTP mode to see I was able now to create Playlists as before.  No, unfortunately - that functionality seems to be gone for good.

 

Appreciate all the guidance, and guess I will just have to learn to love using the Clip Zip MSC mode.