Reply
Newbie
Posts: 2
Registered: ‎02-24-2016

sansa clip+ doesn't show up on mac el capitan

hello everyone, the sansaclip+ works, it plays songs and when i connect it to the usb port it charges, the problem is that it doesn't appear on the mac. the mac doesn't show it on the desktop, doesn't show it in utility disk nor in the system report under the usb category, so the mac does not recognize the device anymore.

 

it worked normally until a week or so ago. i tried to format it, i tried to set the usb mode to msc, mtc or auto detect and nothing works. what can i do? now my device is completely empty and not usable. i have tried to connect it to a linux pc with ubuntu on and it doesn't show up there either.

 

what can i do???

SanDisk Guru
Posts: 15,984
Registered: ‎04-17-2008

Re: sansa clip+ doesn't show up on mac el capitan

Try a different cable. Just because it charges doesn't mean the data portion of the cable doesn't have a break in it.

Newbie
Posts: 2
Registered: ‎02-24-2016

Re: sansa clip+ doesn't show up on mac el capitan

i can't try another cable because this device doesn't use a normal mini-usb so i only have this one

SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: sansa clip+ doesn't show up on mac el capitan

Yes, the Clíp+ indeed does use a standard mini-B USB cable--any should work.

SanDisk Guru
Posts: 15,984
Registered: ‎04-17-2008

Re: sansa clip+ doesn't show up on mac el capitan

And they are cheap enough; you could buy one. Smiley Wink

Highlighted
Newbie
Posts: 2
Registered: ‎02-01-2017

Re: sansa clip+ doesn't show up on mac el capitan

[ Edited ]

As delivered, the USB Mode setting of the Sansa SanDisk is set to "Auto Detect".  The Auto Detect USB Mode is not compatible with Ubuntu for some reason in that the disk images cannot be mounted.  I have not tried this with other Linux distros to date.

 

For Ubuntu (and probably other Linux distros), simply set the USB Mode on the Sansa to either MTP or MSC - both work.

 

For MacOS Sierra, I used the short USB cable that came with the Sansa product to connect - no issues at all, even in Sansa "Auto Detect" mode.  Since I am no longer running "El Capitan", I couldn't say whether it works or not.  Can you upgrade to Sierra?