Reply
Newbie
Posts: 3
Registered: ‎04-10-2017

Sansa clip won't turn on but recognized on PC

Hello guys, 

 

Infortunately, 2 months after the warranty expired, my sansa + doesn't turn on anymore. However, it is recognized by my computer and I can access all the files. I searched it and did the reset. Nothing happens but after 15 seconds of holding the power button, I hear the windows disconnect sound meaning it did reset : it then reconnects back to the computer few seconds later. I then found it was just the screen that was dead so I plugged in headphones and pressed random buttons to try and  get a music playing but to no avail.

I also put the latest firmware and it doesn't seem to do anything, I really hope it's not gone for good, is there anything I can still try ?

 

Thanks in advance

Newbie
Posts: 3
Registered: ‎04-10-2017

Re: Sansa clip won't turn on but recognized on PC

bump

Newbie
Posts: 3
Registered: ‎04-10-2017

Re: Sansa clip won't turn on but recognized on PC

Sorry for posting again quick update : I guess only the screen is dead. I dismantled it completly and saw no visible damage but one good thing is that I managed to make it work. The only problem is the display not working as I can now hear my songs, switch, etc.. (almost lost my right eardrum when it finally worked haha).

 

I don't know how I made it come back to life as I tried several things before dismantling it few months ago. I was just looking at the songs on the computer then I told myself why shouldn't I try plugging in headphones ? I did that then I clicked random buttons, put the volume at the max and heard a static noise. That's when I realised it wasn't dead Smiley Happy

 

Newbie
Posts: 1
Registered: ‎11-05-2017

Re: Sansa clip won't turn on but recognized on PC

I recharged my clip + last week to get ready for ski season and found the same problem. No display, no visible response to charging. Any progress on fixing yours, or time for dismantle and replace?

SanDisk Guru
Posts: 16,082
Registered: ‎04-17-2008

Re: Sansa clip won't turn on but recognized on PC


skialpine wrote:

I recharged my clip + last week to get ready for ski season and found the same problem. No display, no visible response to charging. Any progress on fixing yours, or time for dismantle and replace?


Try resetting it. It might just be playing possum.