Showing results for 
Search instead for 
Do you mean 
Reply
Newbie
tombadil
Posts: 1
Registered: ‎03-06-2011
0

Sansa Sandsik Clip+ 8gb Internal Memory Full - no files to delete

I filled my Sansa Sandisk Clip+ full of mp3s. As you can see, there's no space left:

However, when I go to delete the files to but different mp3s on, I only have about 1gb of mp3s to delete:

 

(As you can see i have selected all the folders, right clicked and chosen 'properties'. I have 'hidden folders' turned on.

 

What am i doing wrong? I can't help but feel it's something stupid..

SanDisk Guru
Miikerman
Posts: 7,316
Registered: ‎12-11-2007
0

Re: Sansa Sandsik Clip+ 8gb Internal Memory Full - no files to delete

Not quite sure what's going on, but to clean matters up, you can format the Clip under its Settings (note:  this will erase all your media content).

SanDisk Guru
Tapeworm
Posts: 15,078
Registered: ‎04-17-2008
0

Re: Sansa Sandsik Clip+ 8gb Internal Memory Full - no files to delete

Could your player in in the infamous Auto Defect mode? Using this, the player will connect in MTP mode when possible, but MSC when not. The fly in this ointment is that your computer can only see files loaded in one mode at a time.

 

So, according to the images you posted your player is now in MTP mode showing the 233 files, 27 folders, Size 1.13GB. I'm guessing the remainder of the memory is taken up by files that were loaded in MSC mode. Try unplugging from your computer, switching to MSC and reconnecting. It's very likely you'll discover the rest of the 'missing' files.

 

The key to this conundrum is to select either MTP or MSC (whichever fits your usage needs best) manually and never to use the Auto mode. You'll probably want to format the device, which will clear the memory and re-load everything in one mode.

SanDisk Guru
neutron_bob
Posts: 5,819
Registered: ‎12-26-2007
0

Re: Sansa SanDisk Clip+ 8gb Internal Memory Full - no files to delete

It is possible that the File Allocation Table is messed up in your device.  The FAT is the master list that tells Windows how much memory is available, and the addresses of this memory.

 

If you connect the Clip+ in MSC Mode, either by selecting on the device Settings > System Settings > USB Mode > MSC, or alternately, you can do this manually by starting with the Clip+ turned off.  Press and HOLD the center button depressed as the device is plugged in to the USB port, and it will connect in MSC mode.

 

You can then use the following guide to Check the Volume For Errors and recover the FAT.  This problem will often give you the "not enough space" error; follow the procedure in the linked guide.  To those familiar with the chkdsk command-line utility, this is the same process, only handled via mouse clicks.

 

Bob  :smileyvery-happy: