Reply
Newbie
airport
Posts: 2
Registered: ‎04-26-2009
0

Sansa Clip won't delete files or accept firmware update

I have a 2GB Clip with 50 songs on it.  I usually transfer files between my computer and the Clip using Windows Explorer.  Now when I try to delete files from the clip that way, they show as deleted in Explorer, but when I remove the Clip from the computer and start it the songs appear again after a "refresh database" process occurs.  (This "refresh" is something that didn't used to happen on startup.)  This same thing happens if I try to remove files one by one using the Clip menu.

 

If I try to ADD files to the Clip from my c:\ drive, I get an error that says the "file doesn't exist, check the path and filename."

 

Thinking it may be the firmware I installed the Firmware Update software.  The software identifies that I have version 1.01.18 that can be upgraded to 1.01.32.  (My "system info" on the Clip says version V01.01.18A.).  The updater downloads the update but it fails on installation and says to "try later". 

 

When I try to update manually with the firmware file (extracting the .zip file and putting the .bin file into the Clip's root folder) it won't transfer.  In other words,if I try to copy m330a.bin from my desktop to the f:\ drive root it won't work and I get an error that says "cannot copy m300a.bin: The request could not be performed because of an I/O device error."   So basically, the same problem of the Clip not allowing me to transfer music files onto the Clip, also will not let me copy the .bin file either.

 

I tried to format from the Clip settings menu and that didn't help.  I'm thinking of formatting the Clip from My Computer which would probably be a greater format, and then trying the updater.  I really don't know, and I am somewhat concerned that if I format from My Computer it may be overkill and I might remove needed system files.

 

Does anyone have any ideas that I can try before calling support?   Right now, I have a Clip that works great with 50 songs that cannot be removed or added to.

SanDisk Fanatic
kmc2005
Posts: 284
Registered: ‎11-05-2007
0

Re: Sansa Clip won't delete files or accept firmware update

Formatting your device under PC won't erase any system files so don't worry.  The only thing that it will erase is all of your mp3 files and everything that is in the device.  So try formatting your device under PC to see if this will fix the problem.  If not, tell me if you have ever plugged this device into a MAC and then into a PC...
Newbie
airport
Posts: 2
Registered: ‎04-26-2009
0

Re: Sansa Clip won't delete files or accept firmware update

Tried to format with 2 different PC's in normal mode and even safe mode (just for grins).  Error message "Unable to complete the format" in all cases. 

 

I've never plugged it into a mac.

 

In fact, I haven't given it a whole lot of use.  I bought it probably a year ago and it worked fine for several months, and then I put it away for several months.  When I started reusing it, the battery was totally dead, but it charged up fine.  Now, it's having this problem.  In addition it's much slower to boot up, and also slower to "goodbye".

 

I wonder if it might have something to do with WinXP service packs?  During the time I wasn't using the Clip, I upgraded my old Dell 4600 to SP2 and SP3.

 

I'm beginning to think it's just corrupted.  Not being able to format is a major issue in that regard.

Newbie
cyberisak
Posts: 1
Registered: ‎01-01-2010
0

Re: Sansa Clip won't delete files or accept firmware update

Over the holidays we did plug our Sansa Clip into a MAC to recharge. Then when I got home to my PC, I plugged in the Sansa to download some files and when I tried to browse its files, I got this message "system call failed."  Am I in deep do, do?
SanDisk Guru
Miikerman
Posts: 7,173
Registered: ‎12-11-2007
0

Re: Sansa Clip won't delete files or accept firmware update

Can you reformat the Clip under its Settings, to clear things away?  Note:  this will delete the content on your Clip.
PJ2
Newbie
PJ2
Posts: 2
Registered: ‎11-06-2011
0

Re: Sansa Clip won't delete files or accept firmware update

I have the same problem, but I did plug it into a mac once. Is there hope?

SanDisk Guru
Miikerman
Posts: 7,173
Registered: ‎12-11-2007
0

Re: Sansa Clip won't delete files or accept firmware update


PJ2 wrote:

I have the same problem, but I did plug it into a mac once. Is there hope?



Please explain what your issue is, and what you have tried?

PJ2
Newbie
PJ2
Posts: 2
Registered: ‎11-06-2011
0

Re: Sansa Clip won't delete files or accept firmware update

like the person in the string of questions and answers, my Sansa Clip can play files already on it, but no files (of various types, music, audiobooks, recordings) can be added or deleted from memory, whether I use the format command from the Clip or from a PC. 

 

At some point--I think after it froze up but perhaps leading up to it--I did plug it into my mac. I don't recall why--but someone on this forum raised the question.

 

Anyway--i can't down load anything to the Clip or erase anything. I can erase files using the PC or manually on the Clip, but as soon as it is disconnected from the PC or turned off  and then on(when erasing by hand), the clip reboots and all the files are still there (and still playable).

SanDisk Guru
JK98
Posts: 2,687
Registered: ‎09-13-2008
0

Re: Sansa Clip won't delete files or accept firmware update

Are you connecting the player in MSC mode? when connected, did you check the properties for the player, and make sure it is not read only? Sometimes Windows like to set files, folders  or devices on its own as read only, and one needs to manually uncheck that. When connected, right click on the player, and make sure read only isn't checked.

SanDisk Guru
Miikerman
Posts: 7,173
Registered: ‎12-11-2007
0

Re: Sansa Clip won't delete files or accept firmware update

This is not good news, if you can't format any which way.  Can you run a Windows chkdsk (error correction) on the Clip drive?  (Right click on it, Properties, Tools, Error-checking.)  Also, maybe (I'm totally guessing) the firmware has become corrupt, and it would help to reapply the firmware (see the firmware upgrade sticky thread at the top of the forum).