Showing results for 
Search instead for 
Do you mean 
Reply
Newbie
noktovizor
Posts: 2
Registered: ‎10-31-2012
0

Sandisk SANSA CLIP + and battery !

I request to all those willing to help. I have two weeks SanDisk Sansa Clip + 8 GB. Plays great, it works ok but the battery is not ok. Charged battery was approximately twice already and each time the battery indicator shows about 40% to the player turns off and the battery information is low. Is this normal behavior?
 
noktovizor
SanDisk Guru
Miikerman
Posts: 7,361
Registered: ‎12-11-2007
0

Re: Sandisk SANSA CLIP + and battery !

How long is your battery lasting?  With "normal" use, 10-12 hours seems to be a norm; for some, up to 14-15 hours.

 

Unfortunately, the player's display screen battery gauge can be a bit "wonky" and inaccurate  You can get more accurate information under the System information screen under the player's Settings.  

Newbie
morda
Posts: 4
Registered: ‎11-13-2012
0

Re: Sandisk SANSA CLIP + and battery !

Hey,

 

I have the same problem. It just dies at around 40%. I think it started happening when i upgraded to firmware 01.02.18.  It also looks like battery life is significantly worse, not just innacurate battery level indicator.

 

Cheers

morda

SanDisk Guru
Tapeworm
Posts: 15,103
Registered: ‎04-17-2008
0

Re: Sandisk SANSA CLIP + and battery !

[ Edited ]

You can try re-installing a previous firmware version and see if that corrects things. If so, this information would be helpful to the dev. team at SanDisk.

 

Try this one:

 

http://mp3support.sandisk.com/firmware/clipplus/clipplus01.02.15.zip

 

and let us know if it makes a difference.

Newbie
morda
Posts: 4
Registered: ‎11-13-2012
0

Re: Sandisk SANSA CLIP + and battery !

[ Edited ]

Hi Tapeworm,

 

I did some checks on 01.02.18 and battery indeed dies at ~40%. I was checking under System settings - Information, not only looking at battery level icon.

2nd thing is I connect it to charge and it stops at ~80%, 82% to be exact. I mean battery icon shows full level, it's not "filling up" anymore, I disconnect, go to Settings - Information and it says 82%. I reconnect and it charges again (battery icon shows 60-70% and is "filling up"). I disconnect immediately while it's charging, and battery indicator jumps to full again, but system information says 83%. I then connect for another charge, which takes 1-2 hours until battery icon is full and now system information says 100%. Hope that helps.

 

Cheers,

morda

SanDisk Guru
Miikerman
Posts: 7,361
Registered: ‎12-11-2007
0

Re: Sandisk SANSA CLIP + and battery !

Most importantly, how long is your playtime? Unfortunately, the Clips' battery gauge is known to be, um, idiosyncratic. (A more accurate picture of the battery charge can be obtained through the System settings/Info. page on the players.)
Newbie
morda
Posts: 4
Registered: ‎11-13-2012
0

Re: Sandisk SANSA CLIP + and battery !

Hey,

 

I haven't measured play time yet but it seems to be decent/acceptable. As I mentioned, I've been loking at System Settings/Info page to check battery level. There are two problems (this is all by looking at System Settings/Info):

1) battery dies at ~40%

2) it stops charging at ~80%, you have to disconnect and reconnect to charge it up to 100% (or it still charges, but you don't know because battery indicator is full and you can't go to system settings while charging to check the level) People will just disconnect it  and use thinking it's full.

 

 

Cheers,

morda

SanDisk Guru
Miikerman
Posts: 7,361
Registered: ‎12-11-2007
0

Re: Sandisk SANSA CLIP + and battery !

As noted, a faulty battery charge gauge and related.  But fortunately, you're getting a full charge or thereabouts (a consolation to be sure).  

Newbie
noktovizor
Posts: 2
Registered: ‎10-31-2012
0

Re: Sandisk SANSA CLIP + and battery !

Hi, I installed 01.02.18 and the player died. Once fired, and he died. No button did not work. Only when I used the START and LOCK button it started. I changed to 01.02.15 and it works. However, the battery indicator on bad points. In addition, the sound is slightly changed, is less bass and quieter. I'll try to go back to 01.02.17 as I had when buying.
SanDisk Guru
Tapeworm
Posts: 15,103
Registered: ‎04-17-2008
0

Re: Sandisk SANSA CLIP + and battery !


noktovizor wrote:
Hi, I installed 01.02.18 and the player died. Once fired, and he died. No button did not work. Only when I used the START and LOCK button it started. I changed to 01.02.15 and it works. However, the battery indicator on bad points. In addition, the sound is slightly changed, is less bass and quieter. I'll try to go back to 01.02.17 as I had when buying.


The firmware version would have nothing to do with this. Most likely you set the Region to Europe and your volume is capped due to the EU regulation. Reset the Factory Settings and choose Rest Of World. Now you should have your HIGH volume setting back in the Music Options.