Reply
Newbie
Posts: 1
Registered: ‎07-28-2013

New Songs Won't Play On SD Card?

I've had a huge problem over the last two weeks or so with my Sansa Clip. First for absolutely no reason at all, all of the music on the internal memory was totally wiped clean. I have since put that music back on there, but now I have another problem.

Every time I try to put a new song on my SD card (which has worked absolutely perfectly for the past five months since I bought it), it will play the song ONLY after I unplug it from my computer. When I turn it off after the new song has been put on it (and after it has actually played it), when I turn it on again, it will only display the song name and artist before skipping to the next song without playing a second of it. This now happens EVERY time I put any new song on.

It is not the music files themselves that is the problem, because whenever I put my songs on the internal memory, there is no problem. This is not a solution, since my internal memory space is almost gone and the whole reason I purchased an SD card was so I wouldn't have to rely on my internal memory.

Is there a way I can reset or reformat my SD card (even if that means deleting the music already on it, which isn't a problem because I have backups)? Or is my card faulty? 

Thanks for any help. 

SanDisk Guru
Posts: 2,954
Registered: ‎09-06-2008

Re: New Songs Won't Play On SD Card?

[ Edited ]

First, check the card. Go to Settings/System Settings/USB Mode and make it MSC. Connect the Clip to your computer. Right-click on the card (Removable Disc). Click Properties, go to the Tools tab and run Error-Checking.

 

I know you've ruled out problems with the files, but let's make sure.

 

Can you see the files on the card from your computer? Search it for  MACOSX. If the albums were ripped using a Mac computer they will have those folders, full of 0kb files with nearly the same filenames as the songs. They aren't the songs--they are finder files for Mac, and the Clip can't play them because they aren't the music. Delete all MACOSX folders and make sure the real songs are on there--they should be at least 1MB per minute of music.

 

If that's not the problem--and it might not be--you should make sure that the songs are mp3 (or .wma or .flac) and not any other format that the Clip doesn't read.

 

But yes, the card might be the problem too. You can certainly reformat the card. Go to Settings/System Settings/USB Mode and make it MSC. Connect the Clip to your computer. Right-click on the card (Removable Disc) and Format it to FAT32. Then try reloading it with an album that you know is working.

 

There's one more thing you might try. This makes zero sense but it can sometimes help. Take the card out of the Clip, make sure all your music on the internal memory is backed up, and Format the Clip with the command under Settings/System Settings. Why would formatting the internal memory have anything to do with the card behavior? I have no idea. But if there's trouble with the card slot, it can help.

 

 

SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: New Songs Won't Play On SD Card?

Personally, I would just start from scratch, again:  move your content from your player and SD card to your computer; reformat the player under its System settngs; reformat the microSD card (you can use the SD Association's formatter tool for that); re-put the latest firmware on the player (see the firmware upgrade sticky thread at the top of the forum); and move your content back on your player.  Hopefully, this combo. platter refresh will help.

SanDisk User
Posts: 62
Registered: ‎06-28-2013

Re: New Songs Won't Play On SD Card?

By any chance, was this dropped? Also, reformatting this would be the first step. This would be to isolate a hardware or a software issue.
SanDisk Guru
Posts: 16,074
Registered: ‎04-17-2008

Re: New Songs Won't Play On SD Card?

[ Edited ]

joelmch wrote:
By any chance, was this dropped? Also, reformatting this would be the first step. This would be to isolate a hardware or a software issue.

 

  1.  Reformatting would not be the first step. The first step has already been suggested.
  2.  Reformatting has also already been suggested.
  3.  Reformatting would not isolate a hardware or software issue.
Newbie
Posts: 1
Registered: ‎11-09-2017

Re: New Songs Won't Play On SD Card?

I HAVE AN ISSUE WITH MY SDHC CARD, ALL THE MANY OF MY TRACKS ARE COMING UP WITH FILE IS DAMAGED WHILE SOME OF THEM ARE PLAYING. 

 

I have tried buying a new SDHC. I had a very old SD MMC type card before all this issue which worked fine but only had 32mb, couldnt play that many songs. Now bought  SDHC 32Gb card which only plays MP3 which is great more songs. No other codecs work as i have checked. I have converted every track to mp3 in i tunes 192 kbps. I do not have a format option fat 32 so i had formated to MS-DOS (FAT) as i have a mac. i have tried from as many as 100 music tracks to just 1. each one creates a shadow file on the original. or simply the track just does not work as says file is damaged when i load it into the Audi car media player SD card slot reader.   

 

I am at a complete loss. please can someone help me. 

Highlighted
SanDisk Fanatic
Posts: 385
Registered: ‎09-12-2015

Re: New Songs Won't Play On SD Card?

Mac computers will create a  "shadow" file (starts with ._    and end with .mp3) for each mp3 file (or any other file) you copy to a FAT formatted drive.

I like to use the Mac utility "HiM" (hidden cleaner improved) to remove all those hidden shadow files.  I use the HiM utility after each file management session using my Mac with the internal memory of my Clip Sport and also my micro SD card.

     I am guessing your Audi car media player may be getting confused by the shadow mp3 files 

 

Here is a link to the website for the free software "hidden cleaner Improved".

     https://roaringapps.com/app/him