Reply
Newbie
Posts: 1
Registered: ‎09-13-2010

Clip player died

Help my sansa clip player just quit playing.It was fully charged.I plugged into my P.C.Nothing comes up on P.C screen or player.

 

Any ideas?    

 

Thanks

SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: Clip player died

Will your player still play?  If so, try other USB cables/ports.  You also can turn the Clip off, put the Clip on hold, and then connect while holding the center button down.

 

If not, did you try a reset (on the original Clip, hold the power switch uppermost for 15-20 seconds or more; on the Clip+, hold the power button down for 20-30 seconds)?

SanDisk Guru
Posts: 16,052
Registered: ‎04-17-2008

Re: Clip player died

 


mjpiche wrote:

Help my sansa clip player just quit playing.It was fully charged.I plugged into my P.C.Nothing comes up on P.C screen or player.

 

Any ideas?    

 

Thanks


 


Miikerman wrote:

 

. . . try a reset (on the original Clip, hold the power switch uppermost for 15-20 seconds or more; on the Clip+, hold the power button down for 20-30 seconds)?

 


This should be the 1st thing to try whenever one of these things acts out of the 'norm'. Smiley Wink
Newbie
Posts: 16
Registered: ‎03-31-2009

Re: Clip player died

[ Edited ]

Adding to the thread b/c mine just died in the same exact way (4gb, 02.01.35). I held the power button on for 1+ minute, and at first it didn't seem to work, but then after that it turned on normally again. Just wanted to confirm that "fix."

Newbie
Posts: 4
Registered: ‎09-14-2010

Re: Clip player died

My Clip+ just died in the same fashion.  It's been working fine since I bought it in November and all of a sudden nothing works.  I've tried multiple times to reset it by holding the power button but nothing happens.  It looks like it's dead.

SanDisk Guru
Posts: 8,152
Registered: ‎12-11-2007

Re: Clip player died

Did you try holding the power button down for 20-30-60 seconds or more?

 

Will the player start if you plug it into your computer?  Will the player start if you plug it into your computer while holding the center button down?

Newbie
Posts: 1
Registered: ‎09-14-2010

Re: Clip player died

hi, when I turn on my clip,a notice appears that only says NOT ENOGH SPACE FOR MUSIC DB. PLEASE FREE 30 MG. And it's all it says.I tried to reset but nothing hapens.and when I plug to PC it automatic turns on but  nothing appears in the PC. Any help?

SanDisk Guru
Posts: 16,052
Registered: ‎04-17-2008

Re: Clip player died

 


tundra2007 wrote:

hi, when I turn on my clip,a notice appears that only says NOT ENOGH SPACE FOR MUSIC DB. PLEASE FREE 30 MG. And it's all it says.I tried to reset but nothing hapens.and when I plug to PC it automatic turns on but  nothing appears in the PC. Any help?


You have corrupted files. Run ChkDsk (Error-Checking) or format your player and re-load your music.

 

 

http://forums.sandisk.com/t5/forums/searchpage/tab/message?advanced=true&filter=openResponse&q=NOT+E...

Newbie
Posts: 4
Registered: ‎09-14-2010

Re: Clip player died

Miikerman wrote:

Did you try holding the power button down for 20-30-60 seconds or more?

 

Yes, multiple times.  I've held down the power button for over 60 seconds.

 

Will the player start if you plug it into your computer?  Will the player start if you plug it into your computer while holding the center button down?

 

No.  No.

 

I've tried everything that you mentioned but nothing works.  I'm pretty sure that it's dead.



 

SanDisk Guru
Posts: 16,052
Registered: ‎04-17-2008

Re: Clip player died


avjunkie wrote:

Miikerman wrote:

Did you try holding the power button down for 20-30-60 seconds or more?

 

Yes, multiple times.  I've held down the power button for over 60 seconds.

 

Will the player start if you plug it into your computer?  Will the player start if you plug it into your computer while holding the center button down?

 

No.  No.

 

I've tried everything that you mentioned but nothing works.  I'm pretty sure that it's dead.



 


OK, here's one last thing to try before scheduling the funeral. Hold the power button on, and a split-second later (or maybe at the same time), press & hold the home/menu button. It's been known to work before.