Posts: 2
Registered: ‎04-07-2017

Ixpand usb 3.0 not working with Iphone 7



Need some help ! Just baught my Ixpand usb 3.0 so that I could clear up some storage space on my Iphone 7 (version 10.3.1) but it has proven to be a bit more complicated than I thaught.


I easily downloaded the Sandisk Ixpand app, but when ever I try to back up my photos it downloads a couple of photos (ex: 78 out of 441) and then the app automatically closes and re-opens without the complete back up.

I have tried numerous things:

- Deleting the app and reinstalling - didn't work.

- Shutting off my iphone and turning it on again - didn't work.

- Downloaded the update for the Ixpand usb 3.0 - it poped up with the fact that it already was updated with the newest version available - so that didn't help either.


I tried to use and back up files from an Ipad mini - could do that with no problems.

Tried then backing up a friends Iphone 6s and could qick and fast back up all her 3558 photos.


Anybody with same problem ? or idea for a solution ?

SanDisk Guru
Posts: 3,961
Registered: ‎07-18-2007

Re: Ixpand usb 3.0 not working with Iphone 7

in setting do you have icloud photo library turned on? If so that could be the issue. Some of the images may not be stored on the phone itself and there could be something going on in the download process that is causing the issue. If icloud photo library is turned on try turning it off and see if you can transfer only the files that are stored locally on the phone. 

Posts: 2
Registered: ‎04-07-2017

Re: Ixpand usb 3.0 not working with Iphone 7

Hi drlucky


I've just checked it and my icloud photo library has been turned off all the time. Thanks for the tip though, would have been great if that was the issue (: