Reply
Newbie
Posts: 4
Registered: ‎10-20-2016

SanDisk Ultra II firmware bug causing slow read/write speeds

[ Edited ]

Hey guys as you probably already noticed there are a few people in this forum including me, who have massive problems with their SanDisk Ultra II SSD performance. I personally have the SanDisk Ultra II 960gb version and a Samsung 850 Pro 256gb version.

 

  • The problem:

When I start my computer and check the sata link speed of my "SanDisk Ultra II SSD" via tools such as Crystaldiskinfo or even the SanDisk Dashboard software, everything seems to be fine and it shows 6gb/s connection speed.

However every time I restart my computer my "SanDisk Ultra II" changes from 6gb/s to 3gb/s in the Dashboard software, lowering my write and read performance by half. My Samsung SSD doesn't have this problem and it's speed isn't affected by a computer restart. Many buddies of mine who bought the Ultra II as well noticed the exact same behaviour.

 

Dashboard shows that my speed is only 3gb/s:

dashboard_nach_neustart.png

 

 

And here is an actual speedtest after this bug occurred just to show that it's not just read-out error:

crystaldiskmark_nach_neustart.png

 

  • Other forum users with this problem:

After searching for help in this forum I came across other uses with exactly the same problem:

 

http://forums.sandisk.com/t5/SanDisk-Ultra-II-SSD/Sandisk-Ultra-2-Low-speed/td-p/356276

http://forums.sandisk.com/t5/SanDisk-Ultra-II-SSD/SanDisk-Ultra-II-drive-sometimes-reports-as-3GB-li...

 

 

  • Possible solution:

After countless hours of research, I managed to narrow the problem down. It appears that it is caused by FirmWare Version 41100RL, which all new SanDisk Ultra II SSDs are shipped with. Now I went on and searched the forums for other SanDisk SSDs and if they might have had similiar problems in the past and behold I actually found something.

 

The SanDisk Extreme Pro SSD actually had exactly the same problem as the Ultra II. If you look at the latest firmware update for the Extreme Pro SSD you can see that SanDisk fixed a Sata 2 speed bug for this model.

 

The release notes of this update state:

- Improved compatibility with certain systems where SATA link sometimes negotiated to SATA 2 vs SATA 3

 

Heres the full changelog of this firmware update:

http://forums.sandisk.com/t5/SanDisk-Extreme-Pro-SSD/Firmware-update-X21200RL-released-for-SanDisk-E...

 

As you can see, SanDisk was able to fix this bug with a simple firmware update and therefore It should be pretty easy for them to fix the SanDisk Ultra II SSD as well.

 

Here is also a video of a Extreme Pro SSD having the same problem as all current Ultra II SSDs from SanDisk:

(Take a close look at the SATA 600 speed changing to SATA 300 after a simple restart.)

 

 

I already contacted SanDisks support via E-Mail but i don't think they are going to help me as their answers seem automated.

I would really appreciate if someone from their techsupport could dig deeper into this problem and tell us what's going on, otherwise I think we have to return our SSD's and get our cash back.

Administrator
Posts: 525
Registered: ‎07-20-2007

Re: SanDisk Ultra II firmware bug causing slow read/write speeds

[ Edited ]

Hello Bonebraker,

 

Welcome to the SanDisk Community and thank you for your detailed report. Since you have submitted a support request to SanDisk customer care a technician should be in contact with you very soon. The support system does send an automated message first however a support technician will follow up with you as well. I ask SanDisk support to reach out to you directly however the email address registered for your community account is not in the SanDisk Customer Care CRM. If you can PM me the contact information you provided when submitting your support request to SanDisk I will request a SanDisk support technician to reach out to you. 

 

Forum Admin

slotmonsta

Newbie
Posts: 4
Registered: ‎10-20-2016

Re: SanDisk Ultra II firmware bug causing slow read/write speeds

Thx for your quick response slotmonsta. I sent you a pm with my E-Mail.

Newbie
Posts: 1
Registered: ‎11-01-2016

Re: SanDisk Ultra II firmware bug causing slow read/write speeds

I am experiencing exactly the same issue with both my newly purchased Ultra II 960Gb drives, both in seperate computers.  These are also running firmware 41100RL, and I can replicate this behaviour.  Normal shutdown and startup is fine, but following any restart - for example after Windows Updates - both drives will drop to a 3Gb/s interface.

I'll be very interested in the outcome.

SanDisk Senior User
Posts: 110
Registered: ‎11-26-2015

Re: SanDisk Ultra II firmware bug causing slow read/write speeds

[ Edited ]

I've got a Ultra II 960 with same firmware....

 

I have this SSD Partitioned into 4 drives...  Speedtest on 3 are about the same, but boot (C drive) is half as fast as other drives...  Don't know why....

 

I tried the restart issue, and mine remains 6Ghz speed of disc buss.. but speedtests report same (C: half as fast).

 

Dell i7 XPS 1702x A19 Bios W7-64

Highlighted
Newbie
Posts: 2
Registered: ‎03-19-2017

Re: SanDisk Ultra II firmware bug causing slow read/write speeds

I have an Ultra II 960GB, but a differant firmware: X35510RL.  According to Dashboard, it's fully up to date.  I'll have to look into this, although I don't think I want to have the 41100RL firmware if it's bugged.  Anyways, I want to ask : has this been resolved?  I'm noticing that mine (installed in an HP Pavilion notebook) the performance has degraded (responsiveness and transfer rates, the health status still shows as 100%), although the Dashboard always shows the interface properly as SATA 3 6GB (even after a reboot).