Reply
Newbie
Posts: 3
Registered: ‎01-30-2017

SSD and random disconnects

[ Edited ]

I'm using an Ultra II 960GB on my Linux system. It's now just over 12 months old (typical) and I am experiencing random disconnects.

 

By "disconnects" I mean it's like the SSD has been unplugged from the system. Sometimes this happens on power-on. No boot drive is found, no matter how many power-cycles or resets, it will not find the SSD. Other times it happens at random while I'm using the computer. When this happens I lose all my work !

 

My root partition and /home partition are both on this SSD so when it disconnects, I can do nothing. No access to a terminal, logs etc. I have to reset the computer.

 

The only way I can get the PC to find the SSD is to gently move the SATA connector on the drive.  It's like there's some kind of poorly made connector on the drive (dry-joint?)

 

I've tried moving the SSD to a PCI SATA III card, new SATA cables, swapping SATA ports on the motherboard but this problem always returns - at random!

 

/dev/sda:

ATA device, with non-removable media
Model Number: SanDisk Ultra II 960GB
Serial Number: xxxxxxxxxxxx
Firmware Revision: X41100RL
Media Serial Num:
Media Manufacturer:
Transport: Serial, ATA8-AST, SATA 1.0a, SATA II Extensions, SATA Rev 2.5, SATA Rev 2.6, SATA Rev 3.0

 

I can't find any ISO file to try updating the firmware - seems that I need to install the Dashboard - but I don't have Windows.

 

Any suggestions?

VIP
Posts: 74
Registered: ‎03-17-2016

Re: SSD and random disconnects

Hi Retro, 

 

Seems there is some issue within the connector or the cabel, it can be either host side or drive side, do you have another SATA device ? If so can you try it on the same port/cable ? 

 

If another drive does not have this issue then we can determine the issue is with the drive connector, we will be happy to provide a replacement for you.

Newbie
Posts: 3
Registered: ‎01-30-2017

Re: SSD and random disconnects

Hi Chushi, thanks for your offer to help.

 

I do have other SATA devices. I use a HDD to store my Steam games but I haven't had any issues with it. When my computer fails to boot, I can go into my BIOS and see the HDD there but no SSD. Also the fact that I have seen the same disconnects on a new SATA3 PCI card would appear to rule out the computer side of things.

 

It appears to me that the fault is at the SSD connector. As I mentioned above, just tapping the connector of the SSD is enough to allow the drive to be recognised again.

 

I really wish this wasn't the case as I now have to look at reinstalling my OS 😣 

Spoiler
 
VIP
Posts: 74
Registered: ‎03-17-2016

Re: SSD and random disconnects

Hi Retro, 

 

Please go to this page to request RMA: https://kb.sandisk.com/app/rmaform

 

You can put link to this forum in RMA reason for our agents to reference. 

 

Thank you and have a nice day !

Newbie
Posts: 3
Registered: ‎01-30-2017

Re: SSD and random disconnects

Thank you for your help Chushi.