Reply
Newbie
Posts: 2
Registered: ‎08-16-2016

"Invalid file name." message when copying directory

I am using SanDisk SecureAccess V3.0 on a SanDisk Cruzer Edge 8GB usb drive. My computer operating system is OS X El Capitan (Version 10.11.6). Every time I drag (i.e. copy and paste) a directory containing files into "My Vault" on my usb drive, I get the following pop-up message: "Invalid file name.". Even though all my files and directories seem to get copied over fine, this pop-up message is really annoying. I should also mention that the pop-up requires that I click "OK" before proceeding further with the copying process (if there are multiple parent directories).

 

Is anybody else seeing this problem? Is it a bug?

error_message.png
Newbie
Posts: 2
Registered: ‎08-16-2016

Re: "Invalid file name." message when copying directory

[ Edited ]

After contacting SanDisk Customer Care (1-866-726-3475), I was told that this is a known problem as there have been a few other reports of it happening. The representative could not tell me if and when this problem would be fixed.

SanDisk Senior User
Posts: 147
Registered: ‎10-25-2013

Re: "Invalid file name." message when copying directory

Hello, 

 

this is very good to know so we are expecting the fix so we can use the software normally. 

Newbie
Posts: 1
Registered: ‎08-31-2016

Re: "Invalid file name." message when copying directory

I'm having the same issue on the 64GB drive.  I bought the drive for the software but the fact that you can't store directories from a Mac makes the software totally useless.  Having to delete.  

 

For what it is worth, the program also crashes if a subdirectory has the same name as the parent directory, leaving the whole database mangled.  Repair (properties>repair) seems to work, but I am not trusting any important data to this program so I haven't bothered checking if repair really completely works.

 

I've reformatted the drive and I'll just use the Mac's builtin FileVault since the person I'm giving this to has a Mac.

SanDisk Senior User
Posts: 147
Registered: ‎10-25-2013

Re: "Invalid file name." message when copying directory

Hello, 

 

at the end its good that you found out a better working alternative solution for you that works

Newbie
Posts: 1
Registered: ‎09-03-2017

Re: "Invalid file name." message when copying directory

I get "invalid file name" when a directory is moved into vault and must it ok to continue which takes too much time.  Please fix or tell us an app that fixes for SanDisk SecureAccess 3.0.

 

Stuart

Highlighted
Newbie
Posts: 1
Registered: ‎05-18-2018

Re: "Invalid file name." message when copying directory

Has anybody already found a solution to this issue? I just bought a Extreme Pro 256GB and have the same problems, no matter if I formated the USB with Ex-FAT or Mac OS Extended (journaled). This topic has been discussed for nearly 2 years now, can it be that no solution has been found so far?