Reply
Newbie
Posts: 2
Registered: ‎10-04-2017

Write amplification factor VERY high, wearout indicator not being reported correctly in software

[ Edited ]

So I've had this drive a little under 2 years (240gb ssd plus, latest firmware Z22000RL according to ssd dashboard). I started having issues with windows locking up a couple months ago and a blue screen here or there, so I decided to have a look at the smart info on the drive. The write amplification factor has been steadily increasing despite relatively small amounts of actual writes to the drive, it is currently at about 35 and was closer to 34 or 34.5 just yesterday. I have trim enabled and have for the entire life of the drive, and only had the page file on the drive for about a month when I was having issues with my storage HDD, otherwise its basically only used as a boot drive with a couple games on it. Here are two screenshots a day or so apart:ssd1.PNG

ssd2.PNG

 

as you can see, there were ~17gb written to the drive in that time period, but almost 6TB of nand writes. It also states a media wearout indicator of .94/.95%, and thus reports health as 100%. based on the total writes to the drive and this forum post, I believe is an error with the firmware reporting the value and is actually at 95%, which is what hwinfo64 reports it as here:

 

hwinfo.PNG

 

Hwinfo incorrectly lists E9 as power on hours but is actually the NAND GB Written value. as you can see value AD (average p/e cycle) is 2865, according to the forum post linked above its calculated based on 3000 erase counts. 2865/3000 = .955 or 95.5%. E6 is value 230, or media wearout indicator, and is being reported as 95.0 in hwinfo.

 

Just not sure what to do at this point. I believe this is enough to consider the drive defective and the possiblity that it fails soon and I lose all my data is there especially since it has been locking up for over a minute sometimes, especially while transferring large files to the drive, but I'm not sure if support will consider this a valid reason for replacement since it hasn't actually failed yet.

SanDisk Guru
Posts: 4,246
Registered: ‎07-18-2007

Re: Write amplification factor VERY high, wearout indicator not being reported correctly in software

there was a FW update to solve this issue but it looks like you are a little late for the update to solve the issue. even if you apply the update you will still have a lot of wear on the ssd. I would contact sandisk and get a replacement and when you get the new drive make sure and update the FW if there are any updates available. 

Newbie
Posts: 2
Registered: ‎10-04-2017

Re: Write amplification factor VERY high, wearout indicator not being reported correctly in software

I've checked for firmware updates in the software multiple times and it says I'm on the latest version, also can't find anything about an update anywhere on the sandisk website. I'll go ahead and contact support and see what happens.