Reply
Newbie
Posts: 1
Registered: ‎04-27-2016

sandisk "extreme 900" (model 960GB) random disconnects on apple macbook 12" retina (usb 3.1typeC)

[ Edited ]

 

 

PLEASE ADMIN add this "new" (actually its not new anymore) sandisk model extreme 900 to the forum product categories

 

i would like to ask something about my "extreme 900", 960GB.

it is listed as tested and compatible in the sandisk product database with my apple macbook 12" retina.

but i get random disconnects, without moving the disc or the laptop, the usb is plugged properly.

connection: "usb 3.1 typeC" goes from the extreme 900 into the (only) port "usb 3.1 typeC" of the macbook 12" retina.

 

the disconnects only happen, when i copy 100 or 200GB of data onto the disc or back.

when it happens, i cannot see the external disc anymore, it shows up after rebooting 3 times, with error "disc may be damaged, you can read, but not write, format the disc", i did reformat 2 times, and got random disconnects the day after, when copying files.

 

could it happen, that, if the macbooks power is at 10 or 20% only, the disc is being disconnected, because it cannot be supplied with enough power anymore? (the extreme 900 has a built in raid0, 2 SSDs inside)

 

 

thanks

 

SanDisk Guru
Posts: 4,194
Registered: ‎07-18-2007

Re: sandisk "extreme 900" (model 960GB) random disconnects on apple macbook 12" reti

Have you had a chance to test it with a full battery? Do you see similar disconnects when transferring large amounts of data? 

Highlighted
Newbie
Posts: 1
Registered: ‎06-07-2017

Re: sandisk "extreme 900" (model 960GB) random disconnects on apple macbook 12" reti

I havwe this same problem - MacBook Pro late 2016, USBC connection. I have tried 3 different USBC cables and that has not changed a thing. Just about 45 minutes ago I connected it. Worked fine. I have my Photo Library on the SD 900 Exterme and all was good. I am using the laptop for work and suddenly an error message popos up that the Photo Library was not available. Using Finder, I cannot see anything on the disk. I can't eject either. So I will reboot and as has ahappened before everything will be fine. I used Disk Utility when "the disk looks ok" and everything checks out fine.

 

Very Frustrated.