Reply
Newbie
Posts: 1
Registered: ‎10-14-2015

Drive keeps opeining and closing on Win 10j

just got new drive and plugged in to charge.  It keeps closing and opening it's windows explorer window and apparently turning off and on as the light goes off on drive when it closes and comes back on.

 

 

SanDisk Guru
Posts: 4,042
Registered: ‎07-18-2007

Re: Drive keeps opeining and closing on Win 10j

Do you have any other computers to try the drive on? Do you see the same result?

 

Do you have a USB AC charger? When you connect the Wiresless stick to an AC charger does the power cycle there as well?

Newbie
Posts: 1
Registered: ‎12-03-2015

Re: Drive keeps opeining and closing on Win 10j

I am having this same problem. I have an old Dell laptop and only after upgrading to Win 10 the drive would disconnect regularly, then about 10-15 seconds later reconnect. Just before disconnecting, the amber led would flash three times, then a disconnect. I do not get this problem when working on any desktop machine (Windows or Mac). I bought a new Dell laptop last week and thought it would be fixed, however, the problem has moved to my brand new 7000 series Dell laptop. The drive is fully charged and works fine as a WiFi hotspot and via Bluetooth. I have also tried turning off the USB power saver feature and the problem remains.

Anyone have any idea why this is happening only on my laptop? Could it be an issue related to some weird Dell driver?
SanDisk Guru
Posts: 4,042
Registered: ‎07-18-2007

Re: Drive keeps opeining and closing on Win 10j

Is the windows 10 machines fully updated? IIRC windows 10 had some issues with USB detection but they should be resolved with the latest Win 10 patches. 

Newbie
Posts: 1
Registered: ‎02-05-2016

Re: Drive keeps opeining and closing on Win 10j

It's still an issue, I updated the device and w10. It keeps disconnecting.

Highlighted
Newbie
Posts: 1
Registered: ‎05-17-2017

Re: Drive keeps opeining and closing on Win 10j - now with Creators update, too

Exactly this very same thing started to happen now on TWO of my computers (old HP desktop and a year old Lenovo laptop) after they got upgraded to Windows 10 "Creators Update" a few days ago.

The very same WFD still works perfectly with my wife's laptop (that is still with the older version of Windows 10). Maybe I'll do a forced update just to see if the WFD becomes obsolete there, too.

 

To make things clear, the WFD is detected by Windows and its icon pops up in the Devices list of the Control Panel, but it disappears after a few seconds... only to pop up again after a while. And this keeps going for ever.

 

I did update the WFD firmware to a version available at sandisk.com/support. No help.

 

Was there any fix to the original question... two years ago?