Reply
SanDisk Guru
Posts: 3,233
Registered: ‎09-13-2008

Re: Can't Read SD Card Anymore / Can't Turn It On?!

Never insert or remove a card while the player is on.

Newbie
Posts: 7
Registered: ‎03-25-2016

Re: Can't Read SD Card Anymore / Can't Turn It On?!


DFELD2005 wrote:

 

1.  Are you aware of the 2000 audio file limit (for internal memory and SD card memory) with FirmWare 1.27 and 1.29?

.  

 2  Maybe your MUSIC.LIB file is corrupted?  You should always use the Eject Command to allow the Clip Sport to properly compile the MUSIC.LIB file after each audio file copying session.  If nothing seems to make this work. Try deleting the MUSIC.LIB file from your SD card.


To your point 2, I found my MUSIC.LIB file. Is it okay I delete it as you suggested? Would a new file be recovered by itself?

SanDisk Professor
Posts: 454
Registered: ‎09-12-2015

Re: Can't Read SD Card Anymore / Can't Turn It On?!

[ Edited ]

So after all these days your Clip Sport is still not properly playing all the audio files on your SD card?   Really sorry to hear this news..

 

I do know that the Clip Sport will automatically create a new MUSIC.LIB file on a newly formatted SD card.  Also, the Clip Sport will automatically recompile the MUSIC.LIB file each time you eject the player from the USB port of your PC.

     I always use the Eject Icon in the "show hidden icons" area of my Task Bar (Win 10) after I have copied files into (and out of) my Clip Sport.  This gives the player a chance to complete all file transfers and then recompile the MUSIC.LIB file.

 

Newbie
Posts: 7
Registered: ‎03-25-2016

Re: Can't Read SD Card Anymore / Can't Turn It On?!

[ Edited ]

DFELD2005 wrote:

So after all these days your Clip Sport is still not properly playing all the audio files on your SD card?   Really sorry to hear this news..

 

I do know that the Clip Sport will automatically create a new MUSIC.LIB file on a newly formatted SD card.  Also, the Clip Sport will automatically recompile the MUSIC.LIB file each time you eject the player from the USB port of your PC.

     I always use the Eject Icon in the "show hidden icons" area of my Task Bar (Win 10) after I have copied files into (and out of) my Clip Sport.  This gives the player a chance to complete all file transfers and then recompile the MUSIC.LIB file.

 


Today I backed up the files on both internal memory and sd card, formatted both of them, and saved the files back to both. On the sd card, there are below 2,000 files. I still have two issues: 

 

  1. Very difficult to turn it on: I can successful turn it on on an average of every 20 tries. Each try I would hold the button for 30-60 seconds. 
  2. Still not reading the card: After "occasionally" I could turn on the Sansa Clip Sport, I was still getting the error message asking me to re-insert the SD Card. I followed it and it was still not reading the card.  

I wonder if I should buy a new one. Although not perfectly, my Sansa Clip Sport had worked for the past year and a half. Maybe it is reaching its life-span? It's very frustrating... Any advice? 

 

SanDisk Professor
Posts: 454
Registered: ‎09-12-2015

Re: Can't Read SD Card Anymore / Can't Turn It On?!

[ Edited ]

       I am sorry to read about your SD card problems.

From all your descriptions it appears to me your SD card is the problem not your Clip Sport. Is your Clip Sport working well with FirmWare 1.29 when your SD card is not inserted in the player??

 

If this is true, then I suggest you buy a new micro SD card with 16 gb size and Class 4. (Not all Class 10 will work with SanDisk players.)  The player does not really need to use a more expensive 32 gb card with the 2000 file limit in FW 1.29.

       Insert the new card while the player is turned off.  Then turn it on and hopefully you will be back to normal.  

 

 

 

 

Newbie
Posts: 7
Registered: ‎03-25-2016

Re: Can't Read SD Card Anymore / Can't Turn It On?!


DFELD2005 wrote:

       I am sorry to read about your SD card problems.

From all your descriptions it appears to me your SD card is the problem not your Clip Sport. Is your Clip Sport working well with FirmWare 1.29 when your SD card is not inserted in the player??

 

If this is true, then I suggest you buy a new micro SD card with 16 gb size and Class 4. (Not all Class 10 will work with SanDisk players.)  The player does not really need to use a more expensive 32 gb card with the 2000 file limit in FW 1.29.

       Insert the new card while the player is turned off.  Then turn it on and hopefully you will be back to normal.  

 

 

 

 


The SD card is 32GB Class 4. It has worked for a long time until I updated Clip Sport with Firmware 1.29. The SD card works fine with my laptop too. 

 

Yes, my Clip Sport works fine without the SD card when I am able to turn it on. But it is very difficult to turn on my Clip Sport now--it wasn't the case until recently. Now I can turn it on successfully once after about every twenty attempts.

 

Do you suggest that I buy a new SD card or a new Clip Sport, or an MP3 play of another brand? The sad thing is that Clip Sport appears to be the best non-iPod music player that is available at the price level. 

 

 Thanks.

 

SanDisk Professor
Posts: 454
Registered: ‎09-12-2015

Re: Can't Read SD Card Anymore / Can't Turn It On?!

[ Edited ]

I am sorry all my suggestions did not help you. And sorry for your Clip Sport troubles.

I have not tried FW 1.29 for myself (still using 1.28 from Sept. 2015).  FW 1.28 is no longer provided by SanDisk website.

 

Before you abandon your Clip Sport maybe try to install FirmWare 1.27 into the root folder of your Clip Sport.

FW 1.27 is still available for download on the SanDisk support website.

      http://forums.sandisk.com/t5/SanDisk-Clip-Sport/SanDisk-Clip-Sport-Firmware-1-27-released/td-p/34060...

 

Follow the installation instructions using the manual update method after you download the "hex" file.

Best Wishes.

 

 

Newbie
Posts: 4
Registered: ‎04-10-2018

Re: Can't Read SD Card Anymore / Can't Turn It On?!

Same problem here. I put the SD card in a PC, everything shows up correctly there, and deleted that LIB file. Put it back in the player, and all is good again.

Good news.