Reply
Newbie
Posts: 4
Registered: ‎10-01-2016
Accepted Solution

Complaint about sorting of tracks in Sandisk Clip Jam

[ Edited ]

I have both Sansa Clip+ and Sansa Clip Jam. I love Sansa Clip+, and I would like to love Clip Jam, but I miss one feature. In Sansa Clip+ I could navigate through the Music -> Folders -> Audiobooks or Podcasts menu and open files in book mode, with all the features of books (ability to change speed, ability to remember last position). In Clip Jam if I open file through Folders, it gets opened as a song, and if I open the same file though Books menu, it gets opened as a book (using data from ID3 tags, I think).

 

Sorting of books does not work the way I would like, because Clip Jam does not take into account TPOS ID3 tag.

 

id3info file.mp3

...

=== TRCK (Track number/Position in set): 3/4
=== TPOS (Part of a set): 2/3

..

 

I would like the order to be 1-1, 1-2, 2-1, 2-2, 2-3, 2-4, 3-1, 3-2

Now it seems that it may be, for example, 1-1, 3-1, 2-1, 2-2, 3-2, 2-3, 2-4 (depending on the title)

 

 

 

SanDisk Fanatic
Posts: 365
Registered: ‎09-12-2015

Re: Complaint about sorting of tracks in Sandisk Clip Jam

Try changing your numbering system to 2-digits (00 - 99) as a prefix in the title field of your ID3 tag. 

(Maybe also use these 2-digit numbers in the track field of your ID3 tag.)

    Change this:   1-1, 1-2, 2-1, 2-2, 2-3, 2-4, 3-1, 3-2

    To this: 11, 12, 21, 22, 23, 24, 31, 32    etc

Newbie
Posts: 4
Registered: ‎10-01-2016

Re: Complaint about sorting of tracks in Sandisk Clip Jam

[ Edited ]

Thanks, but I think it's worth fixing. I am sure a lot of people do not know how to change ID3 tag. I am sure a lot of people haven't heard about it.

SanDisk User
Posts: 53
Registered: ‎12-13-2014

Re: Complaint about sorting of tracks in Sandisk Clip Jam

Unfortunately, editing the ID3 tags is probably your only way to address the sorting issues. As I understand it, all the manufacturer which uses the same SoC as Sandisk does in the Clip Jam suffers from identical limitations, suggesting this is not something that can be easily solved in software by Sandisk.

Newbie
Posts: 4
Registered: ‎10-01-2016

Re: Complaint about sorting of tracks in Sandisk Clip Jam

If it can't, it can't, but if it can, it would be nice if this problem was fixed in firmware upgrades.

 

Also, it would be nice if the feature of opening a podcast or an audiobook as a song after navigating through folders was reverted (Sansa Clip+ does not have this feature).

SanDisk User
Posts: 67
Registered: ‎10-08-2010

Re: Complaint about sorting of tracks in Sandisk Clip Jam

I remember using the Clip+ and using the folder option for Podcasts which gave you the Podcast features as well. This was the ONLY player that had this feature. This feature though wasn't even carried over to the Clip Zip which only allowed folder view in Music but not for Podcasts and when searching by Folder could only access the Music Folder but not the Podcast folder. This led me to creating albums for my podcasts and learning this method which worked fine for me and got used to doing it this way. This + this chips limitations would seem that this is not something that is going to change. 

Newbie
Posts: 4
Registered: ‎10-01-2016

Re: Complaint about sorting of tracks in Sandisk Clip Jam

clipfan7, thanks for the historical overview.

 

I wrote this command, this seems to order capters/episodes in file name order in Linux. I haven't tested it thoroughly yet.

 

 

ls *.mp3 | sort | awk '{print "id3v2", "-T", NR, "\"" $0 "\""}' | bash

 

 

Highlighted
Newbie
Posts: 2
Registered: ‎01-13-2017

Re: Complaint about sorting of tracks in Sandisk Clip Jam

I have Clip Jam MP3 Player. The following solution helped me to have all files in a audio-book in order.

 

I use Linux, and eyeD3 tool preinstalled.

 

For the given audio-book the index of tracks was in the file name:

name001.mp3
...
name300.mp3

So, an index number can be extract useing grep tool: 

grep -oP '\d\d\d'

First, I removed all ID3 tags:

for f in *.mp3; do eyeD3 --remove-all $f; done

Second, I set ID3 title filed to the track's index:

for f in *.mp3; do i=`echo $f | grep -oP '\d\d\d'`; eyeD3 --to-v2.3 -t $i $f; done

 

Done.

 

At this point, if you copy all files to Audiobooks fulder of your Clip, they will be in correct order. However, Artist and author will be shown as "Unknown", wich is not nice. In this particular case I set them like this (text is in Cyrillic) :

for f in *.mp3; do eyeD3 --set-encoding=utf16-LE -A 'Доктор Живаго' -a 'Борис Пастернак' $f; done

 

Hope it'll help you.