Reply
Newbie
Posts: 3
Registered: ‎05-01-2016

Re: cannot format micro sd, believe me, i tried everything

This fault seems to be pretty common considering... does anyone if SandDisk issued a recall for this faulty product?

Newbie
Posts: 2
Registered: ‎09-23-2014

Re: cannot format micro sd, believe me, i tried everything

Did you try formatting it from your computer? I just found a quick solution that worked for me. Check it from bestmicrosdcard.com

Newbie
Posts: 1
Registered: ‎01-15-2017

Re: cannot format micro sd, believe me, i tried everything

Hello All

 

I´m both glad and sad upon seeing this. Seems like a common problem? I have run my 64GB micro-SDXC in my Xperia Z5 without any problems for 1yr+. 

All of a sudden, while in a call the phone froze and was totally unresponsive. I removed the card and phone works fine. However I cannot format the Card? I´ve tried through varios electronics (camera, phone) as well as my Mac and Win 7 Computer. Including the software SD-Formatter. 

 

Just contacted Sandisk support by mail. We´ll se what happens. 

 

Or has anyone found a sollution for this?

Highlighted
Newbie
Posts: 1
Registered: ‎02-12-2017

Re: cannot format micro sd, believe me, i tried everything

Ok, so I recently got a DJI Mavic Pro drone. This Thursday I was flying with it in the morning and filmed some very important footage. I then went to work and spent the day not looking at the footage. I now pulled up the card on my Mac OS X and it was saying that the card is not recognizable by the system. Then tried the switch in different locations, no difference.

 

It's showing up on the system as a 30.6mb. And can not be formatted in any way shape or form with anykind of software or using DOS on  Windows computer which I just picked up as most data recovery or SD Format tools are only for Windows.

 

Well nothing has worked so far. I've tried 10+ different software, most of them don't even show the card.

 

It shows the file system as RAW. Locked/Read only, eventhough that's not the case. It is an San Disk Ultra 64gb Micro SDXC I 10.

 

Test disk says no partition found or selected for recovery.

Format on DOS says not having sufficient priviledges, even in administrator mode.

EaseUS Data recovery tool says it has 0mb data.

SDFORMATTER4 says card is write protected and can not format the  card.

My DJI app said it can not compelete a format on this card.

My Olympus OMD camera says it can not recognize the card.

My Canon 6D is also not showing the card any love.

 

I have been using a MicroSD adapter, I've used a card reader, no difference in choise of tools. I've also tried a few different adapters if one would be malicious, tested with other SDXC cards and they work flawlessly. Just not this one.

 

I've read countless forum posts, articles and tried everything of my knowledge and what I have learned so far except a Linux computer. I feel like if none of this did it, that might not either and I would just spend 1h installing it and then end up still not getting it to work...

 

Read this post by a SanDisk member earlier in this thread with no resulsts other than the card is gone. But what why how?!

http://forums.sandisk.com/t5/All-SanDisk-USB-Flash-Drives/my-sandisk-cruzer-glide-8gb-flash-drive-ha...

 

And then did not find any helpful tools or tips here http://forums.sandisk.com/t5/All-SanDisk-USB-Flash-Drives/HELP-how-do-i-reomove-write-protected-mess... or here http://forums.sandisk.com/t5/Mobile-memory-professional-cards/32GB-Class-10-Micro-SD-card-unexpected...

 

So what happened once it was ready filming the footage from the drone?

 

This thread as many others looks like it's been created a long time ago and it's still not solved. Why is this happening?!