Posts: 1
Registered: ‎09-15-2017

Can't delete any files


I have a problem. I can't delete any of my files from my external storage (SanDisk SD-card). I tried to delete files by using my xiaomi manager; Total Commander; I even tried to delete them through my tablet and laptop — to no avail. I tried to format my SD-card on laptop, but system said that the operation cannot be done. When deleting files on my smartphone, it says nothing. All I can see is progress bar (from 0% to 100%) and files won't disappear after that. By the way, when deleting files manually by using laptop (shift+del), files disappear from my SD-card, yet they appear again after a while.

Please, help me to resolve this issue.

SanDisk Guru
Posts: 4,403
Registered: ‎07-18-2007

Re: Can't delete any files

it sounds like the card has locked itself into write protect mode. the card will need to be replaced. contact sandisk support to check warranty status. 

Posts: 10
Registered: ‎07-20-2017

Re: Can't delete any files

Right click the disk where SD card is and choose "Property" -"Tool" to check it.