Reply
Highlighted
Newbie
Posts: 1
Registered: ‎02-11-2018

SanDisk USB 3.0 Ultra Flash Drive random errors when used from WinPE

Hello

We make a USB3.0 Utra Flash Drive a WinPE Bootable drive.
We connect it to a Lenovo Laptop , power on  the laptop, and activate the laptop BIOS Boot Setup to select the SanDisk USB FlashDrive as the boot device.

Under WinPE execution, scripts in the USB Flash Drive performs imaging of the laptop SSD drive to make is a new Windows 7 bootable system.

Sometimes it works fine.
But sometimes, during the WinPE phase, while  the script  verifies big files by computing their MD5 hash (with fciv utility) , we get an error message:

"The system cannot find the path specified" and also "Device not detected"

as if the USB suddenly disappears for a while from the laptop.

This appearing disconnection (or file access failure)  is temporary and possibly transient because at the end of the script execution,  the USB Flash Drive volume is present and readable again: a dir command at WinPE command line shows it contents correctly.

Have you heard of such possible issues? Could  you please help us?

PS: we fear that this happens only with specific instances/lots  of USB Flash Drives because the error reports from our sites are very sporadic.

 

Thanks

 

 

 

SanDisk Guru
Posts: 2,478
Registered: ‎07-23-2010

Re: SanDisk USB 3.0 Ultra Flash Drive random errors when used from WinPE

Warm boot vs cold boot.

 

Low voltage power source.

 

USB drive not safely removed after last use.

 

Overcrowded USB hub.

Ed
Important files = Backed up files