Reply
Newbie
Posts: 11
Registered: ‎11-21-2016

Re: SanDisk Secure Access V3 fails to start

What about data already encrypted. All the solutions I read seem to suggest complete overwritting existing files. Can anyone tell me how I get my files back when suddenly SanDiskSecureAccessV3_win won't open? Have I lost everything?

 

Benon1

SanDisk Guru
Posts: 2,351
Registered: ‎07-23-2010

Re: SanDisk Secure Access V3 fails to start

"SanDiskSecureAccessV3_win won't open? Have I lost everything?"

 

Yes.

 

Without knowing what error you're getting it's hard to know what the problem is. But you should try using the drive in a different USB port and in a different pc to see if you can get SecureAccess to run again. And try running chkdsk on the drive.

Ed
Important files = Backed up files
Newbie
Posts: 11
Registered: ‎11-21-2016

Re: SanDisk Secure Access V3 fails to start

Tried different port and pc except I can't run any scan on the drive. I guess the encryption won't allow that. Even scanned entire pc with Recuva except sandisk wouldn't let scan in. My guess is chkdsk probably won't either. When I click on "SanDiskSecureAccessV3_win" program reports following 4 dll's missing, LEAuT32.dll
SETUDAPI.dll, COYPT30.dll, WIN M.dl. I downloaded the executable again, renamed to R_SanDiskSecureAccessV3_win and copied it in the drive and I can open that one with no issues. With that in mind do you still think I have lost everything? It's my second sandisk drive that comes out with such an issue. The first one suddenly stopped allowing any writte-in. At least it didn't prohibit me from accessing my files. this second one never gave me the opportunity to even get to the backup point since I just got a new pc and was transfering things.

SanDisk Guru
Posts: 2,351
Registered: ‎07-23-2010

Re: SanDisk Secure Access V3 fails to start

"My guess is chkdsk probably won't either."

 

A bad guess IMO especially since it takes only a minute to run and may fix the missing files problem.  The missing files to me implies you are not Safely Removing the drive when your done using it.  Check your Windows settings for the USB drive and be sure they are not set for Performance rather than Safety.   

Ed
Important files = Backed up files
Newbie
Posts: 11
Registered: ‎11-21-2016

Re: SanDisk Secure Access V3 fails to start

Ed,

That is a smart enlightning guess. Indeed those issues I keep on having seem to all have began when I inadvertantly removed the USB drives without using the eject command in open devices. I didn't imagine that can be such big a deal. I will look in the settings (at least for future use).

SanDisk Guru
Posts: 2,351
Registered: ‎07-23-2010

Re: SanDisk Secure Access V3 fails to start

And before you give up on the flash drivers, open a Command Prompt and run chkdsk on them.  It will correct the errors in their File Allocation Tables.  Which may fix the access problems to you files.

Ed
Important files = Backed up files
Newbie
Posts: 11
Registered: ‎11-21-2016

Re: SanDisk Secure Access V3 fails to start

I haven't been able to figure out how to configure the USB drive to Safety only (Can you please tell me how to in windows 10? I didn't find the settings in device manager). In the mean time I was able to run chkdsk. Chkdsk was able to recover most of the lost files however still having my error. Maybe if I can change the settings as suggested then there would be a chance.

Newbie
Posts: 11
Registered: ‎11-21-2016

Re: SanDisk Secure Access V3 fails to start

It is worth mentioning that since running chkdsk windows now recognizes the drive again when I connect to a com port but SanDiskSecureAccessV3_win still won't open with the same missing 4 dll error.

Newbie
Posts: 11
Registered: ‎11-21-2016

Re: SanDisk Secure Access V3 fails to start

...also the drive folder has SanDiskSecureAccess Vault and SanDiskSecureAccess Settings folder with config.dat and filesystem.dat in it. I was just wondering if the SanDiskSecureAccess Vault and/or the 2 files above can be used to recover missing dlls or maybe dare I dream, something else?.

Newbie
Posts: 11
Registered: ‎11-21-2016

Re: SanDisk Secure Access V3 fails to start

The vault opens fine