Reply
Newbie
Posts: 2
Registered: ‎02-15-2018

Cruzer Edge v2.0 Can't Read Vault Since Application Prompted for me to Accept T&C's

Today I connected my SD Edge 8GB. This flash has been in use for 2-3 years without issue, but today it behaved unusually and I can no longer browse the content of my Vault. Below are the steps I took:

 

1. When connecting the USB today, I opened Explorer, and noticed Windows did not display the usual drive name, it just called it 'USB Drive' by default.

2. I launched Secure Access v2.0.exe and a pop-up said "Secure Access has detected an update (to v3.0) is available". I clicked Cancel, and then it launched another window prompting me to accept Terms & Conditions, click Next etc. I clicked cancel again, detecting something was not right.

3. I physically removed the flash drive, then reconnected the flash drive to another port. The same behaviour was repeated. I physically removed the flash drive again.

4. I rebooted my PC in case there was some weird issue since it had previously awoken from sleep.

5. I connected my flash drive again after boot.

6. On launching the Secure Access.exe it prompted for upgrade again. Argh! I copied all the contents of my Vault onto my C:\ then removed the flash drive.

7. I disabled my WiFi, reconnected the flash drive, launched the Secure Access file browser, and it again said it detected an upgrade available.

8. I clicked CANCEL on the upgrade and the window closed. Another window opened (as in steps 2,3,6) asking me to accept the Terms & Conditions, so I did. It then told me to change my password. I made the password the same as before.

9. The file browser opened and it showed no files! The Vault still shows files, and I have a copy in C:\ of the encrypted files.

10. I relaunched the Secure Access.exe and proceeded to follow the upgrade suggestion to v3.0. It went through ok. It seemed to accept my password but a window now reports:

 

   Failure reading the filesystems file (err=1)

 

I fear by accepting the upgrade in step 10 I've nullified any chance of me accessing the encrypted files now, since the Vault was written/created in v2.0 but the .exe is in v3.1.

 

FYI, I have another Cruzer Edge running v3.1 which I upgraded a year ago and is running fine, used everyday.

 

Can anyone help with a suggestion please?

 

Thank you

 

James

 

 

 

 

 

SanDisk Guru
Posts: 2,520
Registered: ‎07-23-2010

Re: Cruzer Edge v2.0 Can't Read Vault Since Application Prompted for me to Accept T&C's

See if running a chkdsk command on the drive then Safely Removing it helps.

Ed
Important files = Backed up files
Newbie
Posts: 2
Registered: ‎02-15-2018

Re: Cruzer Edge v2.0 Can't Read Vault Since Application Prompted for me to Accept T&C's

Hi Ed,

 

Chkdsk on the USB did not find any errors.

 

I have taken these steps since:

 

1. Deleted the SecureDiskv3.0 from the Cruzer, as it seemed this version was not doing anything when launched.

2. Installed SecureDiskv2.0 on the Cruzer. Launched, set up password to match the old backup one.

3. Tools > Restore > selected the backup data from my C:\. It removed the old vault from the USB, and restored the backed-up files from my PC, onto the Cruzer.

4. After completion, ejected Cruzer, re-inserted, opened app. It opens using the same password as previously (always) used.

5. The App opens, but no files can be browsed, despite the backup data now existing in the Vault since the restore.

 

It seems there is no way I will be able to access the contents of the backup.

SanDisk Guru
Posts: 2,520
Registered: ‎07-23-2010

Re: Cruzer Edge v2.0 Can't Read Vault Since Application Prompted for me to Accept T&C's

Unfortunately I agree.  The vault's files; their location, their sequence, their size all got changed when you used Windows to copy them to and from the hard drive and I think SecureAccess uses that data with it's security scheme.

Ed
Important files = Backed up files